Access violation toad.exe

Buen dia Carlos,

Todavia tengo tu archivo. Manana, lo probare y te dire lo que encuentro.

Siento por falta de acentos.

Good morning John,

Today I run a single instance and when I hit load the workspace I got the error again.

I can't use my workspaces.

Hi Carlos,

Which workspace did you try? I just tried your Proc-Emision-Fact-Distribucion workspace and didn't have any error.

Do you only have the error when multiple Toads are running? Or when you use the "windows desktop" feature?

I run a single instance with the workspace: temporal-1 and it gives me an error

I'm not having any problems loading your workspaces (including temporal-1) using 64 bit Toad 16.2.

I noticed in your error log that Toad had been running for 22 minutes before you got the error.

Do you get the error if you just

  1. start Toad
  2. don't make a connection
  3. choose a workspace

The steps I follow are:

0.- I verify that there are no Toad instances
1.- I open toad
2.- I do not open a connection to any database.
3.- I select the temporary Workspace-1
4.- Error comes out


I see the tab says "Modified" for the package body.

Was the file modified on disk since the last time you saved the workspace?
Or modified in the database?
Or something else?

I have tried all of those things and I can't get (Modified) to appear when loading the workspace. I don't know if this is related to the problem or not, but it is the only thing that I see as different.

I opened the previous version of toad (16.1) and noted all the files that I had in temporary workspace-1.
Then I opened the new version of toad 16.2 and manually opened each file and saved them with the same temporary workspace-1.
I closed everything and reopened and no longer had the problem.

I think the problem was generated when importing the "User Files" folder...this is because since I updated to the new version I haven't touched anything except the "User Files" folder that you told me to restore.

Thank you very much John!

Hi Carlos,

Thanks for the info. That gives me an idea on what to try next.

In the mean time, I'm glad you at least have a workaround.


1 Like

Good morning Juan, tell you the following:

I'm opening 2 instances (with different workspaces) without problems, but the 3rd instance with a different workspace, the instance terminates abruptly.

I have tried opening the 3rd instance with another workspace and it opens normally
...there must be some problem with the workspace that I want to open (see the image with number 3).


I have performed the same operation with the previous version (16.1) and it opened everything without problems.

In case it happens again and I would like to restore the workspace, is there a file where the workspace configuration is saved?

Thank you very much John

Hi Carlos,

Thanks for the info. I'll try to reproduce this.

Workspaces are stored in the file "Workspaces.dat" in the user files folder.


I can reproduce the last one. It just fails when loading the 3rd workspace. You don't have to load the others first. I will log it and hopefully we can have a fix for this soon.

1 Like

Excellent John!
Thank you

Good morning John!

I keep getting "Access violation at addres...." problem

I created this workspace from scratch with the new version 16.2

Yesterday, I added that file "cli--Commissions--Email.sql"

What I intuit is that there is some kind of problem or conflict when a file is modified from another place or instance and the current instance identifies it and labels it with "(Modified)".

The problem is that it doesn't let me open the workspace because when I get the message "Acces violation at addres...." it closes the instance.
In this case, I cannot recover the workspace from the previous version (16.1) because they are new files.

toad-162--error.txt (140.1 KB)

Hi Carlos,

If you are willing to use the beta version, this should be fixed in Monday's beta. I don't know of a workaround for this problem in 16.2. It seems to be more likely to happen when there are a lot of editor tabs open.

If you want to, you can move the workspace from Toad 16.2 to 16.1 like this:

  1. shut down Toad 16.2 and 16.1.
  2. Rename the file Workspaces.dat in 16.1 (to preserve it)
  3. Copy Workspaces.dat from 16.2 to 16.1
  4. Start Toad 16.1

I am sorry for the inconvenience. You may want to just use 16.1 for a while instead of 16.2.


Yes john
I think I will return to version 16.1
...and to avoid confusion I will uninstall version 16.2

John, will this be fixed in the new version you are working on?
...or is it preferable that, in my case, I always keep version 16.1?

Hi Carlos

I believe I have have this fixed for 17.0. I am not 100% certain because I wasn't able to reproduce all of your errors, just some of them. If you are able to test it in the beta on Monday to confirm it is fixed, that would be helpful. If you are not able to try the beta, I understand.


Ok John, I'll test it in the beta.
Should it be from Monday or can I do it from tomorrow?

...and about the beta...I imagine there are daily modifications...every time there is a modification to the beta, should I install a new beta installation or is it just one??
...I have never installed the beta version.

Hi Carlos,

Here is what you need to know about beta:

  • You need to have 16.2 installed (and run at least one time) in order to use the beta.
  • The beta will import your settings from 16.2, and then use its own copy of settings after that.
  • The beta is updated only 1 time per week, usually on Monday
  • When a new beta is available, an icon will appear in Toad that you can just click to download and install the update (no need to remove the old beta first)
  • You can get it here
  • There is a list of changes each week in the comments at the bottom that page.
  • The fix for the workspace bug is not in the current version of the beta, but it will be in Monday's update. So just wait until Monday.


Okay John, I'll do it first thing Monday morning.