Toad World® Forums

After upgrade to new TIC, uploading workbooks from Viewer doesn't work

After installing the upgrade of TIC (along with latest version of TDP) I can’t upload workbooks from the TDP Viewer any more, it mentions a version of Decision Point but I can’t find where that should have been installed and whether that is part of the TDP, TIC and/or TDP Viewer package:

After clicking “Publish Workbook” I get the following error message twice:

Viewer_error1.png

Then I get the “Publish to Toad Intelligence Central” Window, clicking on the default folder to change where to publish it nets me:

Viewer_error3.png

Trying to publish it in the default “No_folder_assigned” folder results in:

Viewer_error4.png

The new version of TIC was installed on a new server afresh and empty so didn’t have any remnants of the previous TIC version. The TDP Viewer is the same version I used with the previous TIC version. The workbook I created uses a view on TIC as data-source and I can successfully Publish the data in the workbook as dataset (even though I get the first error message from above and I can only publish in the “No_folder_assigned” folder as choosing another folder triggers the second error winodwo from above.

The first message about newer version of TIC is just information not an error and you should not worry about it.
The second error tells that you are not connected to TIC.
Could you try to verify that the TIC is running and you can connect to it? To do it open Toad Data Point and create TIC connection to the server. After you verified that you connected to TIC please verify that Toad Data Viewer uses the correct TIC connection. To do it select OPTIONS page and click on Intelligence Central Manager button to see TIC connection.

Regards

Aleksey

I tried again and I can confirm that I am connected to TIC as I was able to:

-refresh the data I got from a View that is published on TIC

-successfully add another dataset from TIC to the workbook

-and I was able to publish a dataset with data from a dimensional view created in the workbook (although only in the “No folder assigned” folder)

Where is the data coming from that is in the workbook? what kind of pages are in the workbook? Can you connect to your datasource and publish that? I can publish a workbook here so I need to find out if it is a specific type of view, etc that does not publish

The Data is coming from a View that is published on TIC, the view is drawing from an Oracle Database.

The Workbook consists of 1 Dimensional View.

I can publish the the data from the View as a dataset with “publish data”.

I tried publishing a workbook that has a (local) .xls file as datasource and a simple dimensional view worktab, also this workbook can not be published as workbook and triggers the same error messages.