Toad World® Forums

ASM Manager not applying attributes to new diskgroups


#1

Also, I’m using 11.2 grid/asm and 11.2 is not a compatibility option in dropdown and needs to be (once applying the attributes is fixed).


#2

Thanks, I’ll take care of that.


#3

Hey Dale,

I just created a disk group and specified non-default values for attributes and it all worked here, so I guess I’ll need some details from you on what didn’t work.

I have added 11.2 as a compatibility level for the next beta (note, it will only appear in the dropdown if you are connected to 11.2 or newer)

-John


#4

I tried changing compatibility and AU size. The Show SQL on both did not have any Attribute clause. I tried modifying an existing diskgroup to change compatibility and it resulted in no SQL being generated. We are at 11.2.0.3 ASM. FYI, I am connected to an 11.2.0.2 database but I had ASM Manager connect to an 11.2.0.3 ASM instance as sysasm on different node. We don’t have any databases yet on these nodes, just grid and ASM but not sure why that should matter.


#5

was the status of the diskgroup DISMOUNTED? Toad won’t apply the changes in that case.


#6

No, not in DISMOUNTED state. When creating new diskgroup, status after Creation is listed as MOUNTED. Increasing Allocation Unit Size to 2MB and/or changing RDBMS Compatibility from 11.1 to 10.1 results in:

CREATE DISKGROUP test

EXTERNAL REDUNDANCY

DISK ‘/dev/mapper/VNXCK1-toss-data-7’ SIZE 250G NOFORCE

/

No Attribute clause in SQL.


#7

I believe when you opened ASM manager, the active connection was to a database older than 11g, and then you made your +ASM connection to the +ASM instance after that. that’s fine, but ideally your ‘main’ connection should be to the database instance associated with the +ASM connection (I know, you said you didn’t create the database instance yet…moving on).

The ‘create disk group’ form was pulling the Oracle version off that connection instead of the +ASM instance connection (a bug), and if that version is less than 11g, we don’t include the attributes clause (since that was not supported before 11g).

I’ll have it fixed in the next beta.


#8

Thanks for the fix. But just so you know, the lowest db versions of any of my connections was 11.2.0.2.

I just tested this against 11.2.0.3 and Attribute clause displays in SQL - though highest compatible version is still 11.1

However, for 11.2.0.2 db and corresponding ASM instance, Attribute clause does not show up for me - which is probably due to fact that the 11.2.0.2 db’s compatibility param is set to 10.2.0.3!


#9

Oh, yeah, in this screen we are checking compatibility. That’s why those values don’t show up.