Toad World® Forums

Automation error msg


#1

I had an automation script running daily for some time, but it fails now with an “Automation” error window stating: "Could not find property or event ‘Trl’ on type ‘Quest.Toad.Workflow.Activities.Database.ConnectionDescription’.

This may have coincided with the date that I changed the Oracle account password for the database in question.

Any suggestions for correcting this?


#2

The password has to be saved as part of your connections defined in TDA. First, check to see if the new password is being saved.

After that, I would go to your automation script and delete and re-add the connection node while you are currently connected. Passwords are not saved in the automation script but it does try to resolve the connection to what you have defined in the application. So if the alias is slightly different this may be the issue also. Redefining the connection should resolve it.

Debbie


#3

Debbie, are you suggesting that I delete the ‘Database Connection’ (orange box in attached picture), and replace the entire contents - Execute script and Select to Editor included? And I would have to do this every time my Oracle password is changed (90 day expiration policy)?

I have already changed the password for the usual connect/reconnect process.

Thanks.
ConnectNode.ppt (56.5 KB)


#4

I am suggesting that you delete the Database Connection and two activities. You could copy the activities first and then delete the connection. This is not something that would have to be done every time you change your password.

The error you have of “Could not find property or event ‘Trl’” is due to opening the automation script in a newer version of TDA and then going back to an older version. ‘Trl’ was an added connection attribute in the automation script.

Debbie

P.S. We are working of improving the version compatibility of the automation scripts. But for now they are not backwardly compatible. In TDA 2.7 we do give you a warning and make copies of the original scripts before adding the new attributes.


#5

I’m thinking it’s something else. First of all, when I check the scheduled run in the morning, after this msg:
“Could not find property or event ‘Trl’ on type ‘Quest.Toad.Workflow.Activities.Database.ConnectionDescription’”,
I get:

System.NullReferenceException
Object reference not set to an instance of an object.
Stack Trace:
at Quest.Toad.Workflow.UI.Designer.GetDefaultDescriptionActivity()
at Quest.Toad.Automation.AutomationForm.CheckforEmailOnErrorWarning()
at Quest.Toad.Automation.AutomationForm.Engine_BuildFailed(EngineEventArgs e)
at Quest.Toad.Workflow.Engine.Run(String fileName, WorkflowService[] services)
at Quest.Toad.Automation.AutomationForm.runInBatchMode(String xomlFile)
at Quest.Toad.Automation.AutomationForm.DoFileOpen(String file)
at Quest.Toad.Gui.MainForm.OpenFile(String file, PredefinedParameterCollection predefinedParameters)
at Quest.Toad.Gui.MainForm.AfterPreStart()
at Quest.Toad.Gui.MainForm.MainForm_Load(Object sender, EventArgs e)
at System.EventHandler.Invoke(Object sender, EventArgs e)
at System.Windows.Forms.Form.OnLoad(EventArgs e)
at System.Windows.Forms.Form.OnCreateControl()
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl()
at System.Windows.Forms.Control.WmShowWindow(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ContainerControl.WndProc(Message& m)
at System.Windows.Forms.Form.WmShowWindow(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at DevExpress.XtraEditors.XtraForm.WndProc(Message& msg)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

I have not downgraded the TDA version, I am currently up to 2.6.1.568.

It only fails when run as a Scheduled job. If I run TDA, open the .TAS and Test run it interactively, it runs with no problem.


#6

Go to the task scheduler and copy and paste the full path of the task. Let’s see where the scheduled task is running Toad.exe.

Debbie


#7

Did you get a chance to look at the path in the scheduled task?

Debbie


#8

Yes, and thank you Debbie!
Just this morning, finally discovered that I had to change the path in both places in the Scheduled Task: the “Run” and the “Start in”.

The problem was that the Run box is too small to show the whole path without closer inspection, which was:
“C:\Program Files\Quest Software\Toad for Data Analysts 2.5\Toad.exe” -batch=true “X:\ReportsBatch\MESQueries\XXXxxxxxXXXX.tas”
so I wasn’t seeing it.

When I upgraded from 2.5 to 2.6, I guess TDA did not automatically modify the path, so I’ll have to remember that upon a subsequent upgrade.

(Since I haven’t uninstalled 2.5, it tries to run, but like you say, 2.5 can’t recognize what 2.6 incorporated).
Case closed.


#9

Thanks for the data. I am glad it is resolved.

P.S. I tried changing this programmatically but it cannot be done for security reasons. Instead I have added a warning message on first start when upgrading that there are scheduled tasks that need a path change. This should help remind a change is needed.


#10

Upgrades can be frustrating. Here is a tip from another Automation user.
Debbie

"I just upgraded to TDA 2.7 and when I tried to use my custom directory it said it was not valid because a previous version was already installed in it. As a result I have come up with the following solution

  1. I created a .bat file on my c drive (named TDA.bat) with the following code
    a. “C:\Program Files\Quest Software\Toad for Data Analysts 2.7\Toad.exe” -batch=true %1
  2. I created a new scheduled task
    a. Run: C:\TDA.bat “C:\TOAD\Test.tas”
    b. Start In: C:
    When the scheduled task runs the batch file it will the run the .tas file (set up as a variable so any new .tas file can be used), when the version changes I will only need to change the version in the .bat file and it will automatically be applied to all of the scheduled tasks.
    I figured I would share this with in case someone else comes across a similar problem again.
    Dave"