Toad World® Forums

Block operations in editor incredibly slow.

TOAD for Windows v 12.11.0.95

If I select a fairly decent sized block of code (maybe a page or so) in the TOAD editor, for example, in the middle of a fairly large package and press TAB to increase the indentation or DELETE to lessen it, it takes an absolute age to do so. The same things happens if I ALT + Mouse drag a caret section and say use SPACE or DELETE.

When developing we’re doing this all the time as part of code formatting, so it’s a great hindrance and a weakness that could do with being addressed.

Just for test, could you disable synonyms and public synonyms in Toa options|Editor|Code Assist.
I suppose that something from this assist is preventing you to be “quick”

I apologize for the delay, Paul. I was away for a bit.

I tried with a large type body (21K lines) thinking perhaps a single, large PL/SQL object may be the ticket, but I cannot reproduce.

Simple text modifications alone should be snappy. Fast edit/execute cycles can be slow; however, as parsing is blocking in that case. There are some blocking operations on edit depending on your options. One that comes to mind is having any of the Character Case settings on the Editor|Font and Styling page set to anything other than Unchanged. I set keywords and others to Upper, but still edit was fast. You can zip and send me your User Files folder and I’ll run it through with your settings. michael staszewski quest.com

Michael

Working with Damir on a related issue, I forgot about the options to highlight table, view, and PL/SQL object names. On the Editor|Display page in options you can disable those and try again. Those options are particularly problematic for very large schemas. The Oracle APPS schema being a prime example. When enabled those options cause noticeable delays for simple edits since the schema owns 10’s of thousands of objects that are cached and searched for each identifier name in your source.

Michael

Hi all,

I can confirm that disable all three highlt options put “paste” action quicker than before…Thx Michael.

Brg,**
________________________**

Damir Vadas
http://damir-vadas.blogspot.com

It does not matter what you have in your life, but who!

Razmislite o čuvanju okoliša prije nego odštampate ovaj e-mail
Please consider the environment before printing this email

On Tue, Oct 17, 2017 at 10:38 PM, Michael Staszewski bounce-mstaszew@toadworld.com wrote:

RE: Block operations in editor incredibly slow.

Reply by Michael Staszewski
Working with Damir on a related issue, I forgot about the options to highlight table, view, and PL/SQL object names. On the Editor|Display page in options you can disable those and try again. Those options are particularly problematic for very large schemas. The Oracle APPS schema being a prime example. When enabled those options cause noticeable delays for simple edits since the schema owns 10’s of thousands of objects that are cached and searched for each identifier name in your source.

Michael

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or Unsubscribe from Toad for Oracle Forum notifications altogether.

Toad for Oracle - Discussion Forum

Flag this post as spam/abuse.