Bug(s) in Toad v10 Session Browser grids?

On the session browser, I’ve noticed a few things with regards to the behaviour of the various grids.

  1. On the main Sessions tab, if you select a cell, it highlights the whole row (not the problem), but when you press CTRL-C, it copies the contents of the cell immediately on the left of the selected cell.

  2. On the other grids within the screen, if you have the Row Select option (from the View -> Toad Options -> Data Grids -> Visual) selected, the grids do not have this automatically set. (Ie. the option in the right mouse menu is unticked and the row does not highlight - just the cell you’re in)

  3. Selecting Row Select on one grid within the tabbed set does not turn it on for all the tabs in that set (eg. Session, Process, IO, etc). Ie. you have to select it for each tab.

  4. Despite Row Select being unticked, if you try to copy a cell (in any grid on the Session Browser barring the main “Sessions Grid”, which doesn’t allow you to choose between Row Select or not) it copies the entire row.

re 2) I think the setting in the options screen is needed, as it defines (or should define) the default behaviour when a screen is opened.

This holds true when I open a new editor window or schema browser (ie. the grids are automatically set to whatever the setting in the options screen is) but doesn’t when I open the session browser. Looks like maybe the check of the options setting is missing from within the session browser?

The grids in Toad have different possibilities for data source.

Ah, ok - that makes a bit more sense now! Thanks for taking the time to provide an explanation.