Toad World® Forums

cannot install TDM 4.1.5: seems a file is missing.

Getting this prompt:

“Click OK to try again, or enter an alternate path to a folder containing the installation package ‘Quest_ToadDataModeler_415.msi’ in the box below.”

Installing in a new machine where nothing or old version is installed. Any idea how to fix this?

tried to install 4.0 but went OK.

Message was edited by: pogz

Hi,

I’ve already responded to your case registered with Support concerning this issue, but here find updated information.
Please, read through all the message before trying anything.

I asked the following in the support case:

  1. The several installations you tried were all with the installer ToadDataModeler_4.1.5.8.msi, or did you also try installing any Quest_ToadDataModeler_415.msi from some other location than is the official standalone installer provided on CD and from product/support page? There are bundle releases and other possible non-Quest releases I don not to know about and may be renamed… (Anyway, have you tried just renaming the installer to that Quest_ToadDataModeler_415.msi? I would be just curious if it would install the renamed installer. You would have to locate the renamed installer from the dialog in the screenshot you sent…)

  2. Please, can you use Windows Disk Cleanup tool from Accessories | System Tools? See the attached screenshots cleanup.PNG and cleanup_options.PNG. Check options Downloaded Program Files, Temporary Files and Temporary Offline Files. Then try the installation again.

The latter question I asked because I thought there must be some temporary file or unsuccessfully finished installation remnant of that Quest_ToadDataModeler_415.msi installer. When you look in Control PAnel | Add or Remove Programs, what installations of TDM can you see? Can you send screenshots, please?
Possible reason for the dialog thrown when trying to start the installer is explained in Microsoft Solution at http://technet.microsoft.com/en-us/library/bb892810.aspx. Again, it says that there must have been installation from that Quest_ToadDataModeler_415.msi installer in the network directory from your snapshot. Windows saves the location for the case of repairs, updates and patches that might be applied in the future. Is that directory still available? It seems you must have that installer that you are being directed to installed, don’t you?

Anyway, is the PC with a brand new XP installation, or is it just a cleaned XP installation or somehow repaired installation? Because we have found that this issue also happens when Windows installation is cleaned or the applications are not uninstalled properly (aren’t uninstalled via their own uninstallation from Add or Remove Programs).

And one more idea. What happens if you use Browse button in the dialog from your screenshot to locate the regular installer ToadDataModeler_4.1.5.8.msi in C:\Temp\TDM 4_1_5? It should update the record in registry with the new location…

Thank you!

Regards,
Lukas