Toad World® Forums

Cannot load OCI - instantclient_11_2\BIN\oci.dll

Hello,
I am using Toad for ORacle 13.1.1.5. It was working fine until recently. I installed Oracle EBS Workflow Builder and toad stopped working. I am getting error:
Cannot load OCI: <>oracle\instantclient_11_2\BIN\oci.dll

oci.dll exist at said location. Also, toad shows Oracle Homes green i.e. no issues but when I try to connect, I get the error. How can I fix it?

Thank you for help.

Toad 13.1 has a bug that if instant client DLLs are in BIN folder, it won't work.

Rename BIN or move everything from bin to the oracle\instantclient_11_2 folder.

Update system path in windows accordingly.

John,

Thank you for quick response. When I tried to copy everything from bin folder to instantclient_11_2, there are two files which are different and exist in both folders. Which one should I keep? the one from instantclient_11_2 folder or bin folder?

Thank you.

Not sure. I would guess whichever is newer, but try one, let us know the file names and the result for the benefit of others.

Hello John,

I keep the latest files from instantclient_11_2 folder. They were from 2012. Bin folder were from 2002.

I updated Path, reboot the computer but still have the same issue.

Please advise. Thank you for your help.

Is the oracle\instantclient_11_2\ location what you were using before or part of the new EBS Workflow Builder installation?

If that was the old, can you start using the client that was installed with EBS Workflow builder? (set it in the "Connect Using" dropdown in login window).

If that doesn't help, you could try rearranging your system path so that the old client that you used to use comes before anything that EBS Workflow Builder added to path.

John,

I was using oracle\instantclient_11_2\ location before installing workflow builder.

Connect Using is showing me only one client as above "Instant Client 11.2.0.3"

My system path is now set to old one of oracle\instantclient_11_2.

I reboot and try again. It did not work.

I just installed Toad for Oracle 13.3 and I am still having the same issue.

here are the details of my ORacle Home :slight_smile:
Instant Client - 11.2.0.3 (11.2.0.3)
ORACLE_HOME:C:\oracle\instantclient_11_2
ORACLE_HOME_NAME:C:\oracle\instantclient_11_2
ORACLE_HOME_KEY:
ORACLE_SID:
NLS_LANG:
SQLPATH:
LOCAL:
Client DLL:C:\oracle\instantclient_11_2\oci.dll
TNSNames.ora:C:\oracle\instantclient_11_2\Network\Admin\tnsnames.ora
SQLNet.ora:C:\oracle\instantclient_11_2\Network\Admin\sqlnet.ora
LDAP.ora:
Login.sql:
GLogin.sql:
In system PATH:Yes
Home is valid:Yes

I'm not sure. I have never installed Workflow Builder before. I just knew about the bug with the BIN folder.

Maybe that bug did not exist in version 13.1, because I guess you had the BIN folder before and it worked. (I know that the bug exists exists in 13.2)

I will try to install workflow builder to see if I can reproduce the problem but I won't be able to get to that today. Let me know what version of Workflow Builder you are using.

John,

I am using workflow builder version: 2.6.3.0.1

Thank you for help.

I will try uninstalling workflow and see if it can make it work. I will update in the post soon.

Thanks again.

Let me know where I can download that from. I am having trouble finding it on technet.oracle.com

John,

Workflow builder is only available via ORacle support link and user needs to have a support contract with their company.
https://support.oracle.com

I just uninstalled Workflow and going to reboot and test it. Will post here soon.

John,

I had to uninstall workflow builder, Toad and instantclint and reinstall instantclient and toad. Finally I got it to work. I will skip the workflow builder as looks like it is creating issues.

thank you for your help.