Toad World® Forums

Cannot load OCI DLL: D:\instantclient_12_2\oci.dll

1.Windows version 7(64bit)
2.toad version 11.6(32bit)
3.client version 12c(32bit)
i can connect to the 11g client,why can not connect 12c? "Cannot load OCI DLL: D:\instantclient_12_2\oci.dll"
anyone help,THKS!!!

Is it because you have actually installed the 64 bit version of the 12c
Instant Client and not the expected 32 bit version?

When you open Toad, go to the Session->New Session option and see if the
12c Instant Client is listed in the drop down for Oracle Homes. Note
that if you have any sessions open using the 11g client, you will not be
able to drop down this list until you disconnect.

There's a button there to get diabnostics too - that might give you a clue.

I'm sorry I can't be more specific, I'm typing "blind" at the moment as
I'm nowhere near my Toad just now. Sorry.

thank you for your enthusiastic reply.
I'm sure that Instant Client is 32 bit and it is listed in the drop down for Oracle Homes.it still throw Exception "Cannot load OCI DLL: D:\instantclient_12_2\oci.dll".

Once you use a client with Toad, if you want to switch to a different client, sometimes you have to shut Toad down completely, then use the different client 1st after restart. If you start Toad, then use one client, then use another client without closing Toad in between, sometime there will be errors like this. The reason isn't completely clear, but I think some parts of the first client stay in memory, and that messes up the 2nd.

I started with a new, clean Windows 7 machine. I installed Oracle 12c instant client (32-bit) and Toad 11.6 (32-bit) and also see the failure. I tried a few things I've known to be problems in the past and nothing is working. I don't have time to dig anymore today, but note that Toad 11.6 predates Oracle 12c so technically this is an unsupported combination. You should upgrade Toad or downgrade your client.

thank you! I started with a new, clean Windows 7 machine,and it worked. may be some error broken the new client ,from regedit.