Toad World® Forums

cannot overwrite text in data grid

In version 10.6 when I was in the data grid in “Schema Browser” and I clicked on a box containing a value the box would be turn green meaning that I had selected it. If I typed a value it would overwrite the existing one but in version 12 the does not overwrite it appears to the left of the existing value.

I can’t reproduce this so I’m not sure how to prevent the problem, but if you hit the ESC key, does that highlight all the data in the cell so you can type over it?

I retested this issue based on your comments and determined that it only occurs on numeric datatypes. If the datatype is varchar2 and the cell is highlighted the text will be overwritten but if the datatype is numeric the text being entered will be inserted to the left of the existing value.

For me, numeric types are working the same as varchar2. Are you using 12.0 or 12.1?

My version is

Ah, I see it happening when I uncheck the “scientific notation” option. It works correctly if that option is checked. I’ll take a look at it

OK, this is fixed for next beta.

Is it fixed in 12.1.1 that is now available

No - John said the beta. That patch was created weeks ago - it takes time between coding and when it hits the streets. The beta is for 12.5 which will debut maybe summer time …