Toad World® Forums

Cannot unistall Toad 2.1


#1

Hello,
I have installed a new version of Toad for data analysts.
Then, I tried to remove older version 2.1; however, I encountered an error.
See the screen shot below.
Any thoughts.
lobs2.png


#2

Hello,

It’s an IBM requirement if a DB2 client was installed as the default DB2 copy and you have other DB2 clients installed, you need to use the Default DB2 Selection Wizard to make one of the other DB2 clients the default copy prior to uninstalling.

You will find the wizard under Start | All Programs | IBM DB2 | TACOM21 | Set-up Tools | Default DB2 Selection wizard

Run the wizard and select another DB2 client other than TACOM21 to be the default client. Once that completes you will be able to uninstall successfully.

Alan


#3

Hi Alan.
The problem is I do not have any IBM products on my desktop.
I only Oracle, Sql Server and MySql.

any thoughts on it or I have to remove everything manually.

Chris


#4

Sounds like the default DB2 copy is set to the one in 2.1. Follow Alan’s instructions and have the default point to the new one in 2.5. You should be able to uninstall after that. Please confirm this worked, ok?

Debbie


#5

I created Cr66,871 to fix for other versions.

Debbie


#6

Hi Debbie,
It did not work as I do not have DB2 on my machine.
It seems like there is no other choice but to do it manually including registry scan.


#7

I do not suggest doing that just yet. See my screenshot. Did you select the 2.5 copy using the menu I am pointing to in the screenshot?


#8

Hi Debbie,
I appreciate your screen shot, but I do not have IBM DB 2 on my machine and never had.

So, it is not going to solve my problem.


#9

The IBM DB2 Client is installed by TDA. You should have this menu. Are you saying you looked on your start menu and you do not have an IBM entry? This should not be the case.

Debbie


#10

Hi Debbie,
I reinstalled version 2.5 and both IBM drivers showed up.
for 2.5 and 2.1
Changed a default setting and it worked.
Thanks for your help and patience.
Best,
Chris


#11

I am glad to see this resolved.