Toad World® Forums

Toad Error Cannot Initialize OCI. Error -1

Hi Everyone,

I’m posting this because I received this Cannot Initialize OCI. Error -1. I have a toad installation on 32 bit windows 2003 server. We’re trying to move away from giving people admin rights. In order for the client to work we need to add the user to the local admin group. If I take them out of this group we get the error.

I’ve tried all of the other fixes mentioned on this board relating to the error including:
Running the program with different compatability modes, adding the bin path to the PATH environmental variable as well as the ORACLE_HOME variable. I’ve tried giving the user read/write permissions to the orace and quest folders. Nothing seems to work short of giving the user local admin.

Any ideas? I read in one post that this could be a bug that was fixed by upgrading to The latest 10gR2 patch. We’re currently using TOAD 9.6.1.1.

Are we going to have to upgrade?

Any help would be appreciated.

Thanks!

Message was edited by: forendan

Are you using a 64 bit Oracle client? Only 32 bit clients are supported.