Toad World® Forums

Change password grayed out for some connections


#1

Our company uses Toad for Oracle 12.9.0.71. I have three connections set to auto-connect (dev, test, prod). I can save the password, auto-connect, and change the password for the prod connection. When I open toad I auto-connect to the instance without needing to enter a password.

For the dev and test instances when I enter the password and choose auto-connect it does not save the password. When I open the connection again the password is not there. The next time I try to auto-connect the password is not there. I cannot try to change the password for this connection (it is grayed out) where I can change the password for the prod connection.

There is obviously something different between these two connections but I can’t figure out what it is.


#2

I figured it out and used this procedure

  1. Open Toad

  2. Open Session -> New Connection from the menu bar

  3. Uncheck Save passwords on the bottom left corner of the window it opens.

  4. For each schema you want to auto connect click on the auto connect check box AND save pwd checkbox for that schema. The save passwords checkbox on the lower left of the window disables the save pwd checkbox on the connection line.

  5. Check save passwords on the bottom left corner of the window.

  6. connect to any schema

  7. close toad

  8. open toad. you will be prompted to enter passwords for all auto connections.

  9. close toad

  10. open toad. everything will autoconnect with saved passwords.


#3

This helped me too. Thanks! VMate
9Apps