Toad World® Forums

Proper Steps to Save New Passwords

Group,

I’m required to change my password that gets me into the database every three (3) months. Of course this requires me to update TOAD with the new passwords (I have two separate schema’s which requires to two separate logins and passwords). As with last time, I cannot get TOAD to save the passwords. I need help!

Can someone give me each individual step that is required to save new passwords?

I have TOAD for Oracle version 12.6.0.53

HELP!!

Thanks in advance.

Don

The usual way to save login passwords is on the new session dialogue. Near the bottom is a checkbox to save passwords. Tick it.

I think there’s an option to encrypt the saved passwords (but I’m away from my Toad at the moment) - if there is, tick it too.

Now type in your connection details, or click on an existing one, type in the password as desired, and connect by clicking the OK button in the usual fashion.

Next time you connect to that one, or any others connected to since you ticked all the boxes, will use the saved and encrypted passwords.

I always set up Toad with this option (or options) ticked, then I forget about it. It’s because I’m lazy!

HTH

Cheers,

Norm. [TeamT]

Norm,

I’ve always checked the “Save Password” box. That doesn’t seem to be doing anything at all. What else can I do?

Don

Is Toad at least storing a password even if it’s the old one or does it refuse to save passwords at all?

Michael

It is storing the old passwords. It just won’t save my new ones.

Are any other Toads running? Check task manager and look for Toad.exe processes that may be running even if you don’t see them in the taskbar. Kill all that you find and try again if there were any. If none were running you could try deleting your previously saved logins and trying again so that new are created. Are you using the Dropbox sync? If so perhaps disable that and try again in case it’s bringing over an older copy of the connections ini file by mistake.

Michael, I did check the Task Manager and see no other instances of TOAD running. I’ve opened the file “C:\Users\userName\AppData\Roaming\Quest Software\Toad for Oracle\11.5\User Files\CONNECTION.INI” and have deleted everything inside it.

I’m not sure what a “Dropbox sync” is. So I doubt I’m using it.

I’ve done a hard shutdown of my computer and have restarted it. I’ve attempted to enter the new passwords. But I don’t know yet if they are saved. I’ll do another hard shutdown and try. I’ll report back.

Cross your fingers.

Don

“C:\Users\userName\AppData\Roaming\Quest Software\Toad for Oracle\11.5\User Files”

This folder should not be used for your 12.6 installation. It should be something like…

C:\Users\userName\AppData\Roaming\Dell\Toad for Oracle\12.6\User Files

Also, you can’t just edit that file directly and have anything positive happen. There are 2 accompanying files and all 3 must be in sync. With Toad closed you can delete ConnectionActions.ini, ConnectionPwds.ini, and Connections.ini to fully remove all of your saved logins.

Michael,

It appears the hard shutdown may have been the fix. I’ve checked both logins and passwords and the both were saved correctly. So I’ll do that moving forward. So my steps will be as follows:

  1. Do a hard shutdown and reboot of my computer

  2. Open TOAD and enter the new password to the first login instance and allow TOAD to completely open.

  3. Close TOAD

  4. Reopen TOAD and enter the new password for the second login instance and allow TOAD to completely open.

This should ensure both logins will have their respective passwords captured and saved.

Thanks again for everyone’s help!

Don

Michael,

I found the files you’re referring to. I’ve deleted the “Quest Software” folder completely. I also found the passwords file. It’s encrypted though, so was of no use. I did find the “CONNECTIONS.INI” file that has a line in it about passwords. It says:

SavePassword=0

Hopefully that is correct. However I would have assumed it would indicate a “1” to imply the passwords were being saved. With this said though, it does appear they are being saved.

For the time being I’m going to go with the information I have. If my tasks set up in “Automation Designer” fail, I’ll be back to inquire. Now that the passwords are being saved, they should run fine.

Again, thanks for the help.

Don

The files are not meant to be edited directly. You should do everything from the login window to avoid corruption. The SavePassword line in Connections.ini is a per login save password setting. There is also a global save passwords option that is not stored in that file. If you intend to save passwords for all of your connections just check the “Save passwords” box on the login screen. You can manage your per connection save passwords option by checking the Save Passwords column for each saved connection where they should be saved.