Toad World® Forums

Code Control Groups Working Directories, Toad 10.6, TFS 2010

Hello,

I am working on a project that includes versioning Oracle DBs using Toad, Team
Coding and TFS2010. We are using MSSCCI provider and Toad 10.6

While setting the environment, I have worked as the domain user tfssetup .

I have successfully set up versioning, configured code control groups and
exported DB object to TFS. Check out/check in logic worked as expected.

The code control groups are configured in the way that one code control group
exists for each DB schema and object type. For example, we have
SCHEMA_1-Functions, SCHEMA_1-Views, ect., SCHEMA_2-Functions, SCHEMA_2-Views,
ect.

When configuring Code Control Groups in the dialog “Code Control
Groups”, in the dialog “Add Group” or “Remap
Group” I have used my local path for the value of “Working
Directory”. This is the same directory where the object belonging to
this group are mapped inside my default TFS workspace on my machine.

The problem appeared when another domain user started working with DB objects
that are now under version control.

When he clicks on an object in Schema Browser the TFS logon dialog
“Connect to a Team Foundation Server” appears. If the user clicks
OK, then the “Choose Folder in Team Foundation Server” dialog
appears and the user can select the team project and his workspace. The value of
the “Local Path” in this dialog is set to the local path I have
previously set up on my machine and cannot be changed (the Browse button is
disabled). If the user chooses his own workspace, the local path value does not
change.

If he, on the other side, clicks cancel on the TFS logon dialog, then he cannot
work with versioned objects. The error “Unable to get revision from VCS
repository.” appears as soon as he tries to checkout an object.

The TFS logon dialog appears more times if the user clicks Cancel.

The only way that I see now how this second domain user can set his working
folder is to go to Code Control Groups and remap each group.

When we tried this, then again, when I logged as tfssetup, I was asked the same
thing to log on to TFS and set up my working folders.

I would like to know why Team Coding behaves this way?

Have we configured everything in the right and expected way?

Is there any general setting that prevents this behavior?

We plan to use about 60 Code Control groups and cannot set up an environment
where users must constantly remap code control groups to their local working
folders.

Why Team Coding and MSSCII provider do not work in sync and use TFS workspace
settings to find out the mappings to local folders?

Thank you very much in advance,

Cheers, Ana

Hi Ana,

Thanks for the detailed outline of your issue… I am trying to replicate and get
some answers to your questions. Do you mind if I contact you offline, if I need
to get more information? I will post the outcome to the group.

As a general response, Mark and I have been taking a hard look at the set up for
Team Coding for version 11, with a view to simplifying the process.

Stephen

Hello,

Thank you for contacting me.

I would be glad to provide you as much info as you need to solve this issue.

We are about to put this project in production at our customer’s site in
the next 4 weeks and the described issue presents a big problem.

We still haven’t exported the initial DB contents to TFS for production
purposes. We are still testing the best settings for their environment and are
therefore still in position to take a “better turn” if one exists.

Looking forward to hear from you,

Ana

P.S. When this new version 11 is going to be availibe?

Toad 11 is due for release in 9/2011

Hello again,

I haven’t got any further replies about the described issue regarding Code
Control Groups Working Directories and multiple domain users.

Has anybody had similar problems and knows a solution?

Thank you in advance,

Cheers, Ana

Ana,

Sorry for the delay , I am still looking at this and recreating here in our
office. There is an issue with TFS2010 and different domain users which I am
working on , which looks similar to your issue. I would be interested to hear if
others have experienced a similar issues.

Stephen

Stephen,

Did you make any progress regarding this issue of code control groups working
folders and different domain users? I am getting the described problem
constantly, each time a different domain user changes the code control groups so
that he can work.

Cheers, Ana

Ana,

I have found an issue with the SOAP interface to TFS with difference domain
users checking out objects. I have tested a code change which partially corrects
the problem, but there are still some issues. We are putting a number of Team
Coding updates in place in the next couple of weeks, which also impacts getting
in place.

One possible work around is to test the switching the TFS provider options to
external command line (i.e using TF.exe). This is slower than the Internal
(direct Connection) option and has the added issue of having TF.exe on the
client. I would test this with one or two users before going further.

Can you tell me what the users are changing in the code control groups to make
it work ? This could be helpful in getting a solution.

Thanks

Stephen