Toad World® Forums

[Code editor] - Multiple line editing does not work properly - ALT gets mixed with windows go to menu

Hy Guys,

When using ALT+click for selecting a text area the selected area is not editable unless you click on another open editor tab and then go back in the initial editor tab you made the selection and start editing.

It goes to menu or it looses focus to the editor tab.

The feature in ssms is described here: http://sqlmag.com/blog/simple-sql-server-management-studio-trick-multiple-line-text-editing.

In Toad 6.6 at least it edits all the rows. In previous versions it would edit only the first line of the alt selection (exceptions copy, paste, delete).

I tried to find the shortcut responsible for go to menu in toad but no luck. I guess if i manage to change the general behavior for ALT then this issue would be partially solved. (most of the chortcuts in this area are general and can’t be changed)

I am using:

OS: 8.1 with latest updates.

Toad 6.1 - 6.6. - the problem is present in all versions.

Hi,

Thank you very much. I reproduce this issue. And I create TSS-1060 for it. We will try to fix it.

Best Regards,

Kelly