Toad World® Forums

Connection List order in Window toolbar list not static


#1

Toad for Oracle Xpert 13.0.0.80

With all previous versions of TOAD I could open a list of windows in a specific order and the order of those windows would never change. My list of connections when clicking the Window (alt+w) toolbar after getting them open might look like this:

1 schema1@server - Editor
2 schema1@server - Schema Browser
3 schema2@server - Editor
4 schema2@server - Schema Browser
5 schema3@server - Editor
6 schema3@server - Schema Browser

Further I could save the workspace and simply load it when I connected for the first time.

I could switch between them all quickly and easily with an alt+w, # method quickly and easily. For instance, if I wanted to go to the editor or schema1 I would press alt+4 (to get the menu) then 1 to select the editor window for schema1.

Now it seems whichever I open last goes to the top causing the whole list to get out of order. I can’t simply perform an alt+w 6 to jump straight to the schema browser for schema3 anymore.

Is there a way to make the order of this list static instead of fluid depending on which window was opened last?

Thank you in advance. I’ve searched and searched using every keyword combination I can think of and not finding what I need.


#2

There’s a button on the login window’s toolbar - about 1/2 across - connection bar button order. If you click that, a dialog comes up. Is the “save connection bar button positions” checkbox checked on that dialog?


#3

Hey calebdhorton,

It looks like this was caused by changes we made to simulate window switching while in SDI mode. It’s been fixed for tomorrow’s beta, if you’d like to try that. Sorry for the inconvenience, but thanks for catching it and telling us about it!

-John


#4

That orders the connection list when starting a new connection and is helpful so thank you for that. It will come in handy.
Unfortunately this doesn’t maintain the order of the connections in the Window toolbar dropdown but apparently there’s a fix coming.

Thanks for the reply though.


#5

Wonderful!!! I was really hoping it wasn’t gone for good.

So this will show up on the https://support.quest.com/toad-for-oracle/13.0/download-new-releases page tomorrow?


#6

The latest version 3.1.0.7 is doing the same thing unfortunately. :frowning:


#7

Hi calebdhorton,

This was fixed for Toad 13.1.0.9 Beta. The current beta version is 13.1.0.10. If you go to Help -> Check for Updates, it should prompt you to download and install the latest version.

-John


#8

I’m on 13.1.0.9 now and it’s working as expected. Thank you very much for the prompt replies.


#9

Hey calebdhorton,

If you have trouble pulling the latest beta through Help -> Check for Updates, you can also download the latest beta update here using the “Update Beta” button:

https://community.toadworld.com/products/toad-for-oracle/toad_for_oracle_beta_program/

-John


#10

I’m glad to hear it’s working for you again! Let us know if you run into anything else.

-John


#11

This started again a few releases ago. I’m on 13.1.0.43 and it won’t save connections in the order in which I opened them.

Any idea when it will be fixed again?


#12

Hi calebdhorton,

I’m trying to reproduce your issue using the latest beta and the steps you outlined in your original post, but I am unable to. The current beta is still retaining the creation order of the windows. Can you elaborate on the steps you’re using to reproduce this?

Thanks,

-John


#13

Are you on 13.1.0.43?

Reproduce by:

  1. Start new session for schema 1
  2. Open schema browser for schema 1 (Alt-D + B)
  3. Start new session for schema 2
  4. Open schema browser for schema 2
  5. start new session for schema 3
  6. Open schema browser for schema 3
  7. Save the workspace

Clicking on the word “Window” on the toolbar should drop down in the following order.

  1. Schema1 - Editor
  2. Schema1 - Schema Browser
  3. Schema2 - Editor
  4. Schema2 - Schema Browser
  5. Schema3 - Editor
  6. Schema3 - Schema Browser

Now close TOAD, start TOAD, and load the workspace created earlier.
For me. They do not show up in the same order when clicking on the word Window.
I get this:

  1. Schema2 - Schema Browser
  2. Schema1 - Editor
  3. Schema1 - Schema Browser
  4. Schema2 - Editor
  5. Schema3 - Editor
  6. Schema3 - Schema Browser

I know it seems petty but it really does make me less efficient. Not a show stopper but frustrating when the workspace doesn’t save like i set it up.


#14

Hi Caleb,

I was able to reproduce this using the steps you provided and logged the issue. It’s been fixed for Monday’s beta. Feel free to give it a try at that point and let us know if you run into any further issues.

Thanks!

-John


#15

I’m now on 31.1.0.45 and still getting it.

opened:

  1. Schema1 - Editor
  2. Schema1 - Schema Browser
  3. Schema2 - Editor
  4. Schema2 - Schema Browser
  5. Schema3 - Editor
  6. Schema3 - Schema Browser
  7. Schema4 - Editor
  8. Schema4 - Schema Browser

But after saving/reloading I get
Schema4 - Schema Browser
Schema3 - Schema Browser
Schema2 - Schema Browser
Schema1 - Schema Browser
Schema1 - Editor
Schema2 - Editor
Schema3 - Editor
Schema4 - Editor

I even tried completely restarting my computer.


#16

Todays beta hasn’t come out yet.


#17

Oh, when I opened TOAD it prompted me to upgrade.
I just assumed 31.1.0.45 was the latest.

Guess I’ll wait for the next upgrade prompt.


#18

@jbowman, Latest release fixed it. Thank you very much.


#19

Glad to hear it, Caleb! Feel free to let us know if you run into anything else.

-John