Toad World® Forums

Copy function slow

Just moved to Toad 12.8.0.49.

When you have a very large package displayed in the editor tab and you want to copy just one line of code or just a few lines of code, when you perform CTRL-C to copy it, it takes a very long time to copy. The package has 43564 lines and it took 114 seconds to copy a single line. In the previous version of Toad that I was using (12.6) it did not have this issue.

Is anyone else having this issue? Any help for it?

I cannot reproduce with a 43,280 line package. I selected a single line and copied. It finished in less than one second.

There are one of two options likely to cause this.

  1. “Copy text in rich text format” on the Editor|Behavior page in Options.
  2. The use of Upper, Lower, or Initial Caps as the Character Case setting for any syntax highlighting style. See the Editor|Font and Styling page in Options. Check all styles on the Global and SQL tabs

Those options add a !significant! amount of work to several simple processes including copy to clipboard, but 114 secs is excessive under any circumstance. Try disabling the Copy in RTF option and removing any of the inefficient character case settings and see if things improve. You can also zip and send me your User Files folder offline and I’ll try again with your settings. michael.staszewskiquest.com.

Michael

On 02/10/2016 11:56 AM, linda.schmidt wrote:

Copy function slow

Thread created by linda.schmidt
Just moved to Toad 12.8.0.49.

When you have a very large package displayed in the editor tab and you want to copy just one line of code or just a few lines of code, when you perform CTRL-C to copy it, it takes a very long time to copy. The package has 43564 lines and it took 114 seconds to copy a single line. In the previous version of Toad that I was using (12.6) it did not have this issue.

Is anyone else having this issue? Any help for it?

To reply, please reply-all to this email.

Stop receiving emails on this subject.
Or Unsubscribe from Toad for Oracle - General notifications altogether.
Toad for Oracle - Discussion Forum

Flag this post as spam/abuse.

Thank you so very much.

The “Copy text in rich test format” was on. I turned it off and it copies in a fraction of a second now.

Thanks again!!!

From: Michael Staszewski [mailto:bounce-mstaszew@toadworld.com]

Sent: Wednesday, February 10, 2016 11:53 AM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Copy function slow

RE: Copy function slow

Reply by Michael Staszewski

I cannot reproduce with a 43,280 line package. I selected a single line and copied. It finished in less than one second.

There are one of two options likely to cause this.

  1. “Copy text in rich text format” on the Editor|Behavior page in Options.

  2. The use of Upper, Lower, or Initial Caps as the Character Case setting for any syntax highlighting style. See the Editor|Font and Styling page in Options. Check all styles on the Global and SQL tabs

Those options add a !significant! amount of work to several simple processes including copy to clipboard, but 114 secs is excessive under any circumstance. Try disabling the Copy in RTF option and removing any of the inefficient character case settings and see if things improve. You can also zip and send me your User Files folder offline and I’ll try again with your settings. michael.staszewski@quest.com.

Michael

On 02/10/2016 11:56 AM, linda.schmidt wrote:

Copy function slow

Thread created by linda.schmidt

Just moved to Toad 12.8.0.49.

When you have a very large package displayed in the editor tab and you want to copy just one line of code or just a few lines of code, when you perform CTRL-C to copy it, it takes a very long time to copy. The package has 43564 lines and it took 114 seconds to copy a single line. In the previous version of Toad that I was using (12.6) it did not have this issue.

Is anyone else having this issue? Any help for it?

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

I also just moved to .49 version

“Copy text in rich text format” on the Editor|Behavior page in Options was on.

After turning it off, the ctrl+c works just like it used to.

Thanks for the question and answer.

Going forward this option will default to off. It only hinders performance and has no positive effect on writing code.

On May 3, 2016, at 6:50 PM, brian.hsu bounce-brianhsu@toadworld.com wrote:

RE: Copy function slow

Reply by brian.hsu
I also just moved to .49 version

“Copy text in rich text format” on the Editor|Behavior page in Options was on.

After turning it off, the ctrl+c works just like it used to.

Thanks for the question and answer.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

Have exact issue on version 12.7.0.121.

The COPY (Ctrl+C) would take an extremely long time to get to into the buffer (1 word, 1 line, multi-line, etc…) … but only took a long time when connected to a db session, not when I opened up my 5k+ line package using just the editor. I turned off the RTF (Copy text in rich text format) option and am back to sub-second copy w/the session connected. Yay, Thanks for the tip!

Now, this is the interesting thing, I went back into options and turned the RTF back on - now I am experiencing the same sub-second copy… weird, but I’ll take it!