Toad World® Forums

Data Compare Reporting vs Automation Results

When executing a Data Comparison, the Data Compare wizard give you a nice summary page, complete with row counts of matched rows:


(don't be alarmed by my mismatch counts!)

Executing the same Data Compare from the Automation doesn't give this count:

It doesn't provide a great deal of comfort to see zeroes in the Equal column. Am I doing something wrong?

I tested this on TDP 5.4 and 5.6, and I can't reproduce this issue.
I'm not aware (and can't find) any options that could affect the report output like this.
Sounds like you've already engaged Support, but may I ask...
If you upgrade to TDP 5.6, does this same Compare still yield all zeros in the EQUAL column?

Same result in 5.6

If you are getting the expected outputs in your tests, can you share your settings in the Compare and Automation files?

Sure thing.... I just noticed that you are doing a cross-platform compare, so i ran another test ... in my case comparing a SQL Server table to a similar table on the Oracle side... (sorry I can't duplicate your exact scenario with same table and source/target platforms).

Snap 1 shows my summary, with expected numbers.

Snap 2 shows the first settings panel from the Data Compare (Wizard) i used.
Note that I hit the ellipsis in order to confirm how I want to compare to happen (e.g. which column/s do I want to use as the compare "key", do I want to compare all columns, how I want to treat NULL values, confirming datatype compatibilities, etc.)

Snap 3 shows the second settings panel from the Data Compare.

Snap 4 shows how I filled in the params for the Compare task in the Automation job.

Hope this helps! If not, might need to let Quest Support know about this, as it doesn't seem right.

That solved it! I was excluding the "Include equal records" to keep my Data Compare local results smaller, but it was still generating the counts.

Are there any storage concerns I should be aware of by going in and changing that "Include equal records" setting?

It certainly seems as though checking the box for "Include equal records" causes a MASSIVE increase in storage requirements and execution time of the data comparisons.