Toad World® Forums

Data Compare throws error on number and date fields

In both 12.1 and 12.5.0.50, I attempted to perform a compare of the data in a view across 2 Toad sessions. The view contains a mix of number, varchar2, nvarchar2 and date fields. I’ve used this feature only rarely, but doco says this should be doable, and the “select columns” screen in the compare data wizard doesn’t flag any of the fields as uncomparable. The error is "invalid value for field xxx’, which is a number field. If I deselect this field from the compare, Toad throws the same error on the next non-character field, which is a date.
toad_dump_20140325.txt (88.3 KB)

I just tried this in toad 12.1.1 and cannot reproduce the error. I don’t doubt that you may have run into something - just suspect I need more info. maybe send the table DDL (no data, can use toad to generate/load data). Also - what options. I did a MINUS. Did you do something different in the settings whcih might be the culprit. Any additional info will help.

It definitely should work for those data types. I’ll take a look at it this morning. The scientific notation option is my first suspect.

Michael, I can’t reproduce it either. I think it’s data related, but that’s just a hunch. Is there any way you can send me the table DDL and data? A portion of the data is fine as long as I can reproduce the problem with it. Email me at john.dorlon@quest.com. Thanks.

Michael and I have been exchanging emails. He was comparing views, and it turned out that one view supported ROWID, but the other did not, and that’s what was causing the problem in Toad. It will be fixed next beta.

Oh, and thank you Michael, for your help in chasing this down.