Data Editing validated by arrow key


i was using an old version of Toad (10) and in the table data, when i was editing a field and pressing the down arrow key , the editing was validated and the field below was seleted.

In Toad 13 , when i press down arrow it does nothing .

Is there a setting for that that i missed ?

thanks for your help


Welcome to the Toad/Oracle forum !

You might need to press Enter (to get out of the Edit mode for the cell you're altering) and then press up/down.

Also, while you're at it, want to draw your attention to some options that may help you identify what "state" each of your altered rows are in, per snap below. Hope this helps.

Hi Gary ,

thanks for your answer and the tips the colors.

This is sad , because in Toad 10, to press down arrow was doing the job. "get out of the Edit mode" and go to next row.

sometime we lose usefull option

We can at least have Quest Dev to see if it's feasible to bring the use case back, or maybe there is an option setting that is preventing the down arrow from working...

Hi SomN,

Somebody else was asking me about this recently. I tried it in Toad 9.7 and I see what you mean.
It is pretty handy. I'll see if I can add it to the next version, but I don't think there is anything you can do to get it in Toad 13. The closest thing you can do in version 13 is use the ENTER key when you are done editing a cell, then arrow down.


1 Like

OK, I see what is happening. This works for most data types, just not VARCHAR2. Try editing a NUMBER field and the down arrow key does just fine.

For varchar2 fields, we are using Memo field type because that displays an ellipsis if there is multiline data. There is also a Text field type, which we don't use because it does not display the ellipsis. But I see that the Text field type handles the Down arrow key as you are requesting.

I am looking to see if there is a way to get both features together.


1 Like

This will be done for the next beta, and in version 16.2, which is due for release next month.

1 Like