Toad World® Forums

Data Grid - Row nn of nn total rows


#1

TOAD 10.1.1.8

When working with large datasets in Data Grids, the ‘group by column’ feature often comes in handy.
Unfortunately the Editor Data Grid (not Schema Browser) insists on counting every row (1,2,3…nn) in ‘Row nn of nn total rows’.
This behavior slows down the process a lot (on our system at least 10 times).
When exporting datasets you can avoid counting every row by unchecking ‘display all results in grid’.
Is there any way to do the same thing when grouping on columns?

One more question.
Is there any way, to make the ‘Read Only’ check-box in the Schema Browser data-grid default to checked?


#2

On second question – I suspect that the toad group policy manager (TGPM)
is what you need to use ….


#3

As far as your data grid grouping question. We couldn’t really do anything
about the full data fetch, so we added a confirmation message before the full
data fetch occurs:

For your second question, there is an option in the main toad options window to
default all data grids to read only (Data grids > Data > Use read-only).
The read-only checkbox won’t get checked (although it probably should),
but the grids will be read-only.

-Brad
image001.png


#4

2nd question: Go to Options -> Data Grids -> Data. Check: Use Read-Only Queries


#5

Maybe I didn’t make myself very clear.

The problem is not the full data fetch, but displaying the row-count in the bottom left corner, seems so slow down the process:
Row 1 of nn total rows
Row 2 of nn total rows
Row …
and so on.

Any way of changing that to every 100th row, 1.000nd or something else:
Row 100 of nn total rows
Row 200 of nn total rows
Row …
and so on

On the second question.
‘Use read-only’ seems to make all the Schema Browser grids read-only until unchecked again.
As I tend to use Schema Browser for browsing (mainly), having the check-box in the Schema Browser grid working exactly the way it does, just being checked instead of unchecked by default, would be nice.
Not a big problem though :slight_smile:


#6

I guess this “Row nn of nn total rows” displaying won’t have the same affect on all systems.
On a PC it might be considerably faster than on our Citrix/Thin-client system.
I noticed though, that if after starting the grouping, you bring some other program than Toad to the front, the displaying stops and you’re back up to speed.
So if you in the Editor Data Grid use the ‘group by column’ feature on large data-sets, you could try this, to see if it works.