Toad World® Forums

Data grid Issue - Always opens in Read-only mode

Hi

I am using Toad version 12.3. Data grid always opens up in READ-ONLY mode for me. I have tried changing View-options-data grid “use read-only queries” , “use immediate edits” but it is still not working. please advise.

12.3? There is no Toad of that version.

Is every table read only? Certain types are tables are read only (such as external tables).

Is everything in Toad read only or just the data grids? For instance, can you run an update statement in the Editor? It could be that you have a read-only version of Toad, or that the “read only” option is checked in the grid of the login window for that connection.

John,

Thanks for quick response.

sorry for the typo. Version is 12.10.0.30. it happens for CLOB fields. I have just found update statement works fine for this field.

OK, so it’s just CLOB fields, not the whole table?

The only thing that I can think of for CLOB is that they might really be XMLTYPEs. (You can check on the “Columns” tab). Toad doesn’t support XMLTYPEs very well, so in the Schema Browser, we cast them to CLOBs and make them read only.

But that wouldn’t stop you from changing them in the Editor with an update statement, as long as they are less than 4K in size.