Toad World® Forums

Data not loading on toad


#1

Dear All,
Kindly assist. I tried loading data to a temporary table on toad using sql loader wizard,but the data was not loaded and i also can’t find the log file to see the error. The mesaage i get on the output tab is ‘Loader is finished’. The ‘Log’ tab is blank while the parameter tab shows me the .ctl file. What can i do?


#2

The data in a temporary table is only going to be visible by the session that inserted it. That’s just how temporary tables work. And SQL Loader creates its own session. So SQL Loader + Temporary Table is not a practical combination.

Either load the data using the session that you want to select it with, or don’t use a temporary table.


#3

Thanks for the feedback, ok maybe my use of temporary table is wrong. I created the table by myself, i’ve always done this before now,my colleagues as well do the same and they can load data to their tables without any issues. What could be missing cos i can’t even locate the .log file that was created on my laptop.


#4

You have to specify a log file in your SQL Loader command. If you didn’t do that, then there isn’t any log file. If you are using the wizard in Toad, the step where you specify the .ctl file should also have a field for .log file.

Before the “Loader is finished” message…is there anything else? Error? Any message about rows being loaded?


#5

I specified the log file location,no error before the ‘Loader is finished’ error.
I eventually found a way around it here: https://community.oracle.com/thread/3652577?start=0&tstart=0.

Thanks for your assitance


#6

I was able to reproduce this with a 12.1.0.2 client - except I got a error “sqlldr.exe has stopped working”, then I tried the trick to copy oraodm12.dll to oranfsodm12.dll and it started working.

Not sure why you didn’t get an error message but I am glad you found the solution.

For me, it worked fine with a 12.2 client, so if you have any more problems, you might want to just get that version.