Toad World® Forums

Data Point 4.3 Editor Autocomplete Speed


#1

I used to use Redgate Sql Prompt at my organization and then we switched to Teradata and the closest equivalent has been Toad Data Point. However, I keep hoping that a new version of Data Point will speed up the autocomplete functionality. Whenever I’m typing in the editor, the speed at which the dropdowns populate after “.” can be very frustrating and slows me down quite a bit.

I don’t know if it’s because our environment is so big that populating all the columns and databases/tables takes a long time? Is it possible to “cache” this information so that it isn’t always creating the autocomplete from scratch?


#2

You’re probably correct that the presence of a high number of database objects are slowing down the type-ahead box within the Editor. Just a suggestion, you may want to try turning off the pop-up type-ahead (within the Options base, select the Editor|Code Completion| General page and turn off the Auto Pop-up check box. See screen capture below.

The pop-up box can be invoked at any time within the editor by pressing on the keyboard. This way, the automatic pop-up shouldn’t slow you down, but you can bring it up as needed.

We can have development take a look at best ways to cache objects, if that helps in this situation.


#3

Here is something else you can test out. Connect to your Teradata instance using the Generic ODBC connection type. You will need to have your Teradata client installed as well as ODBC driver. We added to this provider caching that persists between sessions. It will not have the Teradata specific support like the Native connection but i would like to test out how much it helps to cache.


#4

Thanks Debbie - I’m going to try this. I was actually going nuts and decided to come revisit this post.

I’m over here hitting ctrl=’.’ trying to get the dropdown to come down and it just takes like 10 seconds to populate each time.