Toad World® Forums

Dialog Box: "Processing Script..."

Hi,

When executing a script using F5, I want the dialog box: “Processing Script…” to not appear… because it prohibits me from multitasking within Toad. This behavior keeps me having to switch to SQL-Developer to multitask…

I have searched the forum for answers to this question and came up with a few pieces of info, but nothing definitive.

Most info seemed to be related to the following settings: a) Execute Queries in threads and b) Execute Scripts in Toad Session.

Many thanks in advance!
John

Alternating to F5 script can be run through QSR or SQL*PLUS.
The first option has almost the same features as F5.
And this F5 script can be also run under separate TOAD instance.

Alternating to F5 script can be run through QSR or

SQL*PLUS.
The first option has almost the same
features as F5.
And this F5 script can be also
run under separate TOAD instance.

/>

Thanks, however I can’t understand your response. Can you explain in more detail? Describe exactly which settings to change?

If you want to run your script using F5 but don’t want TOAD to lock up while you do it you can instead execute the script in Quest Script Runner (QSR) or SQLPlus. You can do this easily by selecting Editor->Execute SQL Via … This will open a QSR or SQLPlus window and will run the contents of your SQL Editor there instead of in TOAD.

You can vote to have this improved here:

http://toadfororacle.ideascale.com/a/dtd/Execute-as-script-to-run-in-a-thread/52700-8477