Toad World® Forums

Dialogs don't show up immediately

Hello,

This is a complaint I’ve had for a very long time, since the days TDM was owned by the Czech company (the product had another name).

I bring it up again because it annoys me greatly and perhaps you can do something about it.

It takes a few good seconds until a dialog shows up after clicking on an entity or attribute.

Let’s say I want to edit the attributes of an entity. I double-click on the entity. It takes 3 seconds until the Entity Properties dialog shows up.

Now, I go to attributes and double-click on an attribute. It takes 3 seconds until the Attribute Properties dialog shows up.

Let’s say I want to modify a check constraint. I double-click on a check constraint. This one is faster, it takes a second.

I don’t understand why the dialogs aren’t snappier. It is disruptive to my workflow because I want to make changes quickly.

I have a decent VM. I’ve used in the past other data modelling tools, power designer data architect and the e/r studio and their dialogs are snappy and fast. I don’t understand why this tool is not the same.

Any hints or suggestions?

Thanks

Hello Costabas,

we did today benchmark tests for opening Entity and Attribute Dialogs of Oracle and MS SQL Server platforms. Duration of open Entity Dialogs was less then 1 seconds, duration of open Attribute Dialogs was less then 0,5 second.

Duration can be different depending on each Entity (count of Attributes etc.)

My configuration is processor i7 2,7GHz, 16GB RAM.

BTW: Speed of open dialog was very improved from first version of Toad Data Modeler.

Regard

Thank you for following up on this.

Just curious, how many entities does your model have? Here are the statistics of mine:

tdm_statistics.png

Here is the processor info of my VM from system information: Intel Xeon X5675 @ 3.07 GHz, 3067 Mhz, 1 Core 1 Logical Processor

I am running windows server 2012 R2 Standard - physical memory 16.00GB

I double-checked again and it takes around 2.40s (I used a sports timer) to open an entity properties or attribute properties dialog.

I am running TDM 6.3.2.22.

I tried it at home on a windows 7 64 bit VM (on a mac) and the speed is perfect. So, it has something to do with my windows 2012 r2 vm. We run McAffee antivirus. I disabled it temporarily and the performance is the same.

Not sure if this has to do with anything, but I use Remote Desktop when I access my windows 2012 r2 VM.

Could you assign one more logical processor (thread) to Virtual Machine? Maybe it help. One core is not many.

Daril

I tried it on a different VM and the speed was good. Come to think of it, I started to see this issue when I switched development to my current VM. My VM has 4 cores - the information in my other post was from one single line in the System Information -> System Summary -> Processor.

I apologize for the false alarm, it must be my VM. And thank you for running the performance test.

You are welcome

Daril