Toad World® Forums

Different code style between formatter and sql tab view

Hi all!

It’s my target to have one code style for the whole team, but I don’t know why it happens

that I get different code styles between the formatter and sql tab view. I would like to have the style from this formatter view,

but what could be the problem, that it looks different? Does anyone have an idea? I am still confused. [*-)]

TOAD SQL Tab-View:

toad-view.jpeg

formatter-view.jpeg

TOAD Formatter View:

formatter-view.jpeg

Thanks in advance!

Regards,

Patrick

You are on a very old version of Toad is looks like. The oldest I have installed is 11.6 and it uses a much newer version of the formatter. What version of Toad are you on? Is the formatter options GUI embedded within Toad’s Options window or is it a standalone application in your version? If a standalone application it’s possible that it is using a different options file. Use the Open button in the formatter options application and select the FmtPlus.opt file used by Toad. It’s going to be in %APPDATA%\Quest Software\Toad for Oracle<toad_version>\User Files, by default.

Michael

Currently we are working with Toad Version 12.6.0.53. No it is not a standalone application, it is embedded in the Toad GUI.

As you can see, I also have this phenomenon when I copy the data from formatter to notepad. Do you have a hint for me, what I can do to solve this issue?

Regards,

Patrick

It seems to be tab stops.

In Options go to the Editor|Behavior page. Note your tab options there (Space, Tab, or Smart Tab) and the tab stop setting.

On the Formatter option page, check your tab stop setting and indent setting there (on the Spacing|Tabs and Spacing|Indenting) subpages.

You’ll want the Toad editor and Formatter settings to match so that you see everything matched as you expect. In 12.10 we finally corrected this and have your Toad Editor tab options apply to the formatter.

As far as pasting into other applications, I assume your tab settings there differ from Toad as well.

Michael, thanks a lot for this hint! Now it works! [:)]