Toad World® Forums

Direct connection through command line

Hi,

On attempting command line connection with parameters toad.exe -c username/password@ip: port@servicename - toad always looks for tnsnames.ora and gives an error if it cannot find the details in tnsnames file, whereas if the same details are entered directly on the GUI, it is able to connect to the database. Tried deleting tnsnames.ora from tns_admin path but it still looks for tns entry and the connection error still persists
Please suggest how to resolve this.

Thanks!

which version of Toad are you using?

Toad for Oracle 12.10

@JohnDorlon - the same connection string when tried on SQL Plus, it works fine.. is there any setting on Toad due to which it looks for the entry in tnsnames.ora ?

I just tried this with 12.10 and it works fine for me.

My connect string was:

toad.exe -c "jdorlon/jdorlon@DESKTOP-VFN94IM:1521/pdb1"

I commented all entries to this database out of my tnsnames.ora. Also tried it without any tnsnames.ora at all. Also removed prior connections from login window.

Can you give some more details?

Edit:
You said:

toad.exe -c username/password@ip: port@servicename

Do this instead:

toad.exe -c username/password@ip:port/servicename

(no space after IP and slash instead of @ for service name)