Toad World® Forums

Disable TOAD reconnect?

Hi - We are run a database monitoring tool which drops the oracle connection if certain criteria are met - specific users, accessing specific tables, columns, etc, to disallow highly privileged users from accessing sensitive data.

The issue we are having is that TOAD reconnects so quickly, it is able to bypass our process and the data grids in the results pane of editor or in schema browser are receiving the data and displaying results.

Is there a configuration setting within TOAD that could prevent the reconnects?

I do not get you.

Are you saying that:

you open Toad

open one grid table data

wait some time when your tool disconnect this session

and wait a little more and toad reconnect by itself?

It is hardly to believe that because “automatic reconnecting” may cause many problems in current sessions and hardly can believe that people from Toad do not understand this.

Brg

Damir

Actually, I’m not aware of any reconnect that happens automatically. We do have reconnect buttons on error messages that come up as a result of a disconnect, and you can cause a reconnect from the main menu: Session -> Test Connection.

Sometimes Toad can create background sessions though, maybe one of those is causing you problems. If you want everything to be done in the same session, go to Options -> Oracle -> Transactions. Make sure “Execute queries in threads” is unchecked. “Execute Scripts in Toad Session” is checked, and “Session for explain plan” is set to “Main Toad Session”.