Toad World® Forums

Toad 10.0.0.41 doesn't seem to like losing connections to the db


#1

I’ve just had the unfortunate instance where a database I’ve been connected to has had problems and my connection to it has died.

In prior versions, just selecting the “Test connections (Reconnect)” menu option has been enough to sort things out so I can continue working on the database now that it’s back.

However, this time, I’ve had various errors:

  • Invalid OCI handle when Testing the connections.
  • Invalid User (I think; I forget the wording now) Oracle error when running queries, although the queries returned results.
  • Query does not have a session (Toad error) - after switching session on the editor window from one db back to the problematic db and attempting to run any query.
  • Access violation at address 01AAD688 in module ‘Toad.exe’. Read of address 00000000 when Testing the connections.

Of course, this might be related to the fact that I recently (yesterday) switched to running queries in the background… or it might not!

Anyone else had any problems?

I’m just about to disconnect and reconnect, to see what impact that has.


#2

Interestingly, before disconnecting, I tried selecting the column tab on one of the tables in the schema on the affected db, and it worked. A new editor window with a new query worked too.

So I switched back to the previous editor window… and all seems fine again.

No more errors, even when clicking back on the Test Connections option.

Self-repairing Toad?! I like!