Display error in TOAD 17.1 Schema Browser

Hi all,

in the new TOAD 17.1 the lines in the Schema Browser (especially in the Functions, Procedures and Packages) seem to be too close, so that (depending on font and size) the underline character is not displayed properly (it looks like a space character instead). My font for left hand side ist Tahoma 8pt (same result for 9pt). I have to increase to 10pt to have the underlines shown, but that is too large for me and steals me to much space. The display problem you can see in the following picture.

Best regards,


Hi Rainer,

Toad's GUI is currently designed primarily for Segoe UI font size 9, but for me, Tahoma 8 looks fine too (shown below). I have tried on a 100% and 200% scaled display on Windows 10. What else can you tell me so I can hopefully reproduce it?

FYI, the schema browser will adjust if you change the font while it is open, but the end result isn't quite the same as if you close/reopen the schema browser after changing font.


Hi John,

one thing I discovered that when I chage the font size for the Schema Browser lhs and save, go into the options again, then the font size is empty. The schema browser I use the following way, and that's all that comes in my mind:

Best regards

Yes, I've noticed the empty font size value in options also. That does seem like a bug, but I don't think it's related.

In your windows display settings, are you using "Custom/Advanced Scaling"?

In Windows 10:

I can send screen shots for Windows 11 if needed. But I have seen this happen before if custom scaling is used (even if it's a "nice" value like 125, 150, 200, etc). Toad can't deal with the big windows "Not recommended" warning. If you have that set, turn it off (you may have to restart after that). Then choose the scaling you want without going into Custom/Advanced.

I use Windows 10 and I think I dont't use advanced scaling - but I'm not sure. Most time I work on my development machine per remote desktop from my home office, and via remote desktop the field for the custom scaling is empty. I will not be in the company before mid of June to check this setting directly at the machine.

But what I see in TOAD 17.1 is that the line size in the Schema Browser is reduced by one or two pixels in comparison to TOAD 17.0. Could that be the problem?

Hi Rainer,

I'll try through remote desktop.

Toad 17.1 is compiled with a newer version of Delphi than 17.0. Delphi made some changes to better support high-DPI environments with MDI applications (which Toad is) because Windows doesn't officially support high-DPI with MDI apps. Their first attempt wasn't perfect but in most places it's an improvement. Unfortunately a few scaling issues were introduced. This is why you are seeing a smaller line height. The value in our source hasn't changed, but it's being scaled. Hopefully we can have this resolved soon. If not, I can introduce a setting to let you explicitly set line height, which should also resolve this.

So far I've only been able to reproduce this with custom scaling like I mentioned before and since Windows has that big "not recommended" warning, I felt OK about telling customers "don't set that".

It looks ok through Remote Desktop for me also. What do you see for scaling settings if you right-click on the remote desktop toolbar?


Hi John,

I get no context when I right-click on the remote desktop toolbar, nowhere. A setting to explicitely set the line height would be great :smiley:

I've added a "Node Height Adjustment" option for next beta. Value is Pixels, so probably just +1 or +2 is all you need.

Sounds great :slight_smile: I will try next Beta as soon as it's available.

And: I like the new numbering system :slight_smile:

Best regards,