Toad World® Forums

editing clob fails


#1

Hello
I’m using SQL navigator 6.1 on an oracle 10 database. If I select and edit a CLOB by selecting a table from the Database Navigator tree and then press the commit button, the changes are there when I reopen the CLOB within the same session but lost once I close and reopen the session.

If I make changes using a SQL UPDATE statement and then press the commit button however, the changes persist across sessions. This is fine for small data items but the CLOB contains a fairly hefty chunk of XML that I need to update.

Any ideas ??

Regards

Mark


#2

Hi Mark,

We haven’t met any case like this yet and I tried to reproduce with updating 20M text to a clob on 10g database but it worked just fine for me. May I ask for more information from you?

  1. what was the size of the clob content that you updated?
  2. did you see message ‘Transaction Commited’ in output window after you clicked Commit button?
  3. did you close the table editor window after commit then open it again to check if the clob was updated?
  4. could you please try to press the commit button in main form toolbar after clicking the commit button in the table editor window, then close current session and reconnect to see if the clob is updated correctly?

Thanks,
Vincent