Toad World® Forums

Task "SQL Editor Execution" in DoTerminate(): Stream read error


#1

Hello there!
After trying to resolve my problem, by searching within this forum, I 've decided to share my problem with you.
I write pl/sql code since SQL Nav 4.x and I am currently using version 5.5.2.xxx.
Since then, whenever I try to “SELECT * FROM MY_TABLE;” and “MY_TABLE” contains CLOB datatype columns, I get this nasty “Task “SQL Editor Execution” in DoTerminate(): Stream read error” and I always have to close the application.
I have never encountered such a problem when using TOAD (any version).
Nevertheless, I still prefer SQL Nav as a development tool.
Do you have any suggestions related to my problem?

Thank you in advance, for your time.
BaBs.


#2

hi ,

welcome to community.
I assume that you are using SQL NAv 5.5.2 and in SQL editor you tried to execute a select * from my_table and got this error in the output.
In order to investigate further we need some more information about your database/client environment and number of columns in the table and data size of the table e.t.c.

  1. What version of oracle client/Server are you using?
  2. How many CLOB columns are in the “MY_TABLE” ?
  3. Did you get this error all the time on that particular table ?
  4. Did you execute the SQL statement in sql editor in Updatable mode or in read only mode ?
  5. Did you choose any custom preferences in SQL nav or all are default ?
  6. You did a Quick Browse from db navigator tree or you typed the query manually and executed?
  7. The database character set information ?(This you can get from “select * from nls_database_parameters”)

Regards
sekhar


#3

Dear sekhar,
Thank you for your interest.
I get the same errors even when the table has count() = 1 and count() = 30000.

  1. Client/Server, both 9.2.0.7.0 (same with client 9.2.0.6.0 and 9.2.0.8.0)
  2. Same error when table_a has 1 CLOB column or table_b has more (…3, 4, 5… clob columns)
  3. I get this error ALL the time (in different PCs - WinXp, Win2k) on EVERY table having CLOB column(s)
  4. Same error in both modes
  5. Same error, either in default prefs or not.
  6. Same error in both ways (Quick browse, manual execution)
  7. SELECT * FROM NLS_DATABASE_PARAMETERS :
    NLS_LANGUAGE AMERICAN
    NLS_TERRITORY AMERICA
    NLS_CURRENCY $
    NLS_ISO_CURRENCY AMERICA
    NLS_NUMERIC_CHARACTERS .,
    NLS_CHARACTERSET AL32UTF8
    NLS_CALENDAR GREGORIAN
    NLS_DATE_FORMAT DD-MON-RR
    NLS_DATE_LANGUAGE AMERICAN
    NLS_SORT BINARY
    NLS_TIME_FORMAT HH.MI.SSXFF AM
    NLS_TIMESTAMP_FORMAT DD-MON-RR HH.MI.SSXFF AM
    NLS_TIME_TZ_FORMAT HH.MI.SSXFF AM TZR
    NLS_TIMESTAMP_TZ_FORMAT DD-MON-RR HH.MI.SSXFF AM TZR
    NLS_DUAL_CURRENCY $
    NLS_COMP BINARY
    NLS_LENGTH_SEMANTICS BYTE
    NLS_NCHAR_CONV_EXCP FALSE
    NLS_NCHAR_CHARACTERSET UTF8
    NLS_RDBMS_VERSION 9.2.0.7.0
    NLS_CSMIG_SCHEMA_VERSION 2

I hope you may find a way to help, since this is a VERY annoying “feature”… I fight all the time with other developers in my company, when they keep on laughing/telling me: “TOAD has never dissapointed us…”

Thanks again,
BaBs.


#4

Hi BaBs,

Thank you very much for the reply. It is helpfull in investigating the problem further. We are working on the issue.
We will get back to you at earliest convinience.
Thanks for supporting nav as a favourite development tool.

regards
sekhar


#5

Hi BaBs,

A question to narrow down the issue further…
Does it happen only on one particular database or does it happen on any database?
We created a similar database with same character set but we could not reproduce so far.
In order to investigate further we will send you a special debug build in one or two days. This will capture all the error related information and help our development team can pin point the issue.

Regards
sekhar


#6

Hi Sekhar,
The mentioned DoTerminate() error DOES NOT appear when the query is being executed upon an EMPTY table. You should have at least one row with CLOB content.
I have executed my query on three different Operating Systems, all having the same Oracle DB release installed:

  1. Windows 2000
  2. Suse 8 Ent.
  3. HP UX
    The error appears in all these ocassions.

Many thanks for your effort.
BaBs.


#7

Hi BaBs,

We still could not manage to reproduce the Stream Read Error which you have reported. However, we could manage getting a different DoTerminate() error when having large Data in CLOB column type using the SQL Editor.

The good news is the New Unified Editor which is available in the upcoming release handles CLOB column type much more effectively. The Unified Editor will replace the current SQL Editor in our current release which you are currently using at the moment.

We would like to ask you if it would be possible for you to download the latest Beta build from (size about 82 MB)

http://sqlnavigator.inside.quest.com/shares/sqlnavigator/sbin/beta/777/sqlnav_6-0-0-777-beta.zip

I am uploading the build for you now, The transfer should be complete in about 45mins.

And install Side by Side, ie. install it into a new location, so that you still could go back and use your current (production) SQL Nav programs. Much appreciated if you could let us know if you still get the same issue with CLOB column using the Unified Code Editor.

We are also looking forward to your feedbacks on 6.0 Beta build and having you using it doing your daily work. This will ensure SQL Nav team will deliver a better product to you and all our users in the next release.

Many thanks in advance.

Best regards,
Bruce

hyperlink fixed!

Message was edited by: MisuBisu


#8

Hi Bruce,
I have already downloaded and tested my query on SQL Navigator 6.0.0.760-beta.
My feedback is:

  1. No DoTerminate() error appears on the Unified Editor. I get a full - correct shown - grid with the resultset and I see the word (LOB) in my CLOB columns. (the error remains in the simple SQL editor)
  2. When I double click on them, to see its content, I get an error and the application “becomes unstable” and I have to close it. I am afraid I cannot reproduce right now the error. I have a statement running on myNav 5.5. that migrates data and needs approximately about one day to finish,so I am anxious whether this will terminate unexpectedly my job running on 5.5. I promise to do so, as soon as I finish my job.

I am currently downloading built 777 to see what happens there.
By the time we get an answer on this peculiar error, I have some other questions related to the functionality of SQL Nav.
(e.g. Why the statement:
UPDATE my_table a
SET a.
WHERE a.
does not pop-up any menu for auto-completion, after the dot)

I am a developer myself, in Powerbuilder applications (UI) and I always find such debugging cases very challenging… :slight_smile:

Regards,
BaBs.

P.S. I had to copy-paste the full url you have recommended to me, because when I tried to click on it, it seemed to be 2 different links. Please, check it yourself. Nevertheless, it’s still OK for me!


#9

Hi BaBs,

It is really good to hear from you that the error does not appear with Beta (UE). We will submit the enhancement request for dot look up for update statements. Hope it will be fixed for one of our future Beta builds.

regards
sekhar


#10

Hi BaBs,
Thank you very much for the update.
Regarding the error you get when viewing the CLOB data in Unified Editor in build 760…

Roman just upgraded ODAC component (connection management component) in build 777 which we believe that it would address this issue for you. We will wait for more update from you soon on build 777.

Sekhar has raised a request on your behalf on the dot look up. Roman will try to get this to you in the next Beta build iteration.

Thanks and regards,
Bruce

PS. Thanks for pointing out the url. Jaime has fixed it.


#11

Well done gentlemen!
In built 777, no DoTerminate() error appears (still, in the UE only ).
When I execute my Select * statement in the UE, the resultset grid appears, writting (LOB) where needed. When I double click on a (LOB) to see its contents, a new tab opens and I can read the contents correctly. Then I click back on the SQL (my query) tab, I double click on another (LOB) and then I get an error:
“Internal error occured; see file ERROR.LOG for details”.
The application halts (becomes unstable and prompts to Save and Exit or Exit without saving).
I still cannot find this ERROR.LOG file that the application refers to. I searched my whole HDD to find it (even in temp folders…), but no such file found. Hence, I can not provide you this log. Do I miss something?

I am afraid I will have to wait for the version 6 of Nav. to solve my “weird” problem… since there seems to be no easy way for you to reproduce it… I 'll be glad to hear from you that you have managed to find what the problem is…

Regards,
BaBs.


#12

Hi Sekhar,
In your post you mentioned something about sending me a “special debug build”. Do you mean built 777? Do I have to expect anything else? (another tool or script or whatever)

Regards,
BaBs.


#13

Hi BaBs,

Thank you very much for your feedback. It is good to hear from you that the error does not happen with UE. We thought of sending you a Debug build but somehow in our testing it does not pick up such kind of errors, so Bruce has posted you to try with our New UE build.
In UE, it uses a different mechanism to display the clob data. But if you can send us one Table of the same type along with 2% of data in it then we can test exactly with the same object here in our test environment. If you don’t have any problem Please try to send us the DDL script along with data for one table (CLOB column one) as a .dmp file using Oracle exp/imp utility. Here I am giving my mail address for you to send the .dmp file.

My mail id: sekhar.bommireddypalli@quest.com

Thanks in advance for you effort and time.

Regards
Sekhar


#14

Hi Sekhar,
I have sent you the requested .dmp and the relative .log file.

Please, check your mailbox.
BaBs.


#15

Hi BaBs,

Your example is really helpful for investigation, but we could not able to reproduce here on our test machines. Before we get a build with fix, could you please try our Latest Beta. It includes fixes for a lot of issues in unified editor. It should perform well on Big CLOB. So if you get a chance could you please share you experience.

You can get the Beta from the following Link

http://sqlnavigator.inside.quest.com/ann.jspa?annID=77

regards
sekhar