Toad World® Forums

Editor - changing Language on existing window from SQL to Text does not eliminate highlighted syntax errors.

I had an Editor SQL window open, pasted in some non-sql text, got a bunch of syntax highlighting, rt-click on language/syntax highlighting changing it from SQL to Plain Text. Red marks remained. When I create the Editor window as a Text window and paste non-sql, no syntax highlighting as expected.

There is probably some room for improvement here, but text highlighting is not the same as a text tab. A text tab does apply text highlighting, but it also eliminates a lot of the helper features specific to coding SQL and PL/SQL. When you are on a SQL or PL/SQL tab and change the highlighting to Text all that you are changing is the styling of tokens. The tab is still geared for SQL and PL/SQL development under the hood so all other features apply including syntax checking and marking of errors.

Michael, thanks for the explanation. This is not something I normally do but I see now that the little tab icon still says “sql” so that should have been a clue, had I looked. So the Plain Text setting basically eliminates auto-formatting like uppercasing keywords, . Good to know - might come in handy.