Toad World® Forums

ERROR: API Guard (QP5 version 5.269.14213.34746)

Hi,

Installed the latest Toad Beta this morning and getting a lot of error messages.

The most recent was this (see attached):

API Guard (QP5 version 5.269.14213.34746)

Function 5026 (QP5_CLS_START_CANCELING)

The only thing I was doing was running a Stored Procedure.
2014-08-12_10-36-23.jpeg

Thanks. I’ll take a look.

On 08/12/2014 10:41 AM, msacks wrote:

ERROR: API Guard (QP5 version 5.269.14213.34746)

Thread created by msacks
Hi,

Installed the latest Toad Beta this morning and getting a lot of error messages.

The most recent was this (see attached):

API Guard (QP5 version 5.269.14213.34746)

Function 5026 (QP5_CLS_START_CANCELING)

The only thing I was doing was running a Stored Procedure.

Attachments:

2014-08-12_10-36-23.jpg

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.

Just got this one when trying to see your reply:

HTTP: 0
2014-08-12_10-55-41.jpeg

Please send me your toad.el file offline (michael.staszewskiquest.com). It’s located in your user files folder. When submitting reports you can also include the call stack (if available) which is most helpful. Screenshots often do little. In your latest screenshot you’ll notice a link to click to see more info. That will reveal the entire error report.

On 08/12/2014 10:57 AM, msacks wrote:

RE: ERROR: API Guard (QP5 version 5.269.14213.34746)

Reply by msacks
Just got this one when trying to see your reply:

HTTP: 0

Attachments:
2014-08-12_10-55-41.jpeg

To reply, please reply-all to this email.

Stop receiving emails on this subject.
Or Unsubscribe from Toad for Oracle - Beta notifications altogether.
Toad for Oracle - Beta Discussion Forum

Flag this post as spam/abuse.

Hi Michael,

“Toad.el” file attached.

I meant to capture the call stack, but mistakenly hit OK to clear the error message after I did the screen captures.
Toad.el (184 KB)

After the HTTP exception did a refresh of the window load the window properly?

On 08/12/2014 11:30 AM, msacks wrote:

RE: ERROR: API Guard (QP5 version 5.269.14213.34746)

Reply by msacks
Hi Michael,

“Toad.el” file attached.

I meant to capture the call stack, but mistakenly hit OK to clear the error message after I did the screen captures.

Attachments:

Toad.el

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.

I believe it did.

Ok, good. Thanks.

On 08/12/2014 01:34 PM, msacks wrote:

RE: ERROR: API Guard (QP5 version 5.269.14213.34746)

Reply by msacks
I believe it did.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.

Any idea what the original issue with API Guard was?

Not at this time. Usually it’s memory corruption. The pointer that I’m passing to the parser is no longer good. I’ve been unable to reproduce and the code has remained somewhat unchanged in recent months. Nothing is jumping out. It was in response to sending
a cancel request to the parser. Cancel requests are sent when we have a parse underway and something happens to invalidate it. Say you paste text and pause. The parser kicks in and while it’s parsing you start typing. Anything the parser is about to tell us
is going to be of no use because the text has been modified. Was this just a simple load procedure and execute scenario? A standalone procedure, not a package proc?

On 08/12/2014 03:22 PM, msacks wrote:

RE: ERROR: API Guard (QP5 version 5.269.14213.34746)

Reply by msacks
Any idea what the original issue with API Guard was?

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.

At the time, I was running something like “EXEC some_procedure;”, and I may have been cutting / pasting text in other editors associated to other connections.

I made a change for the next build. I have not been able to reproduce the issue and can see only one possible way for this to occur, but it would require perfect timing. I’ve removed that vulnerability and hope that it knocks this out. I assume that we’ll have
another public beta so please grab it when released and let me know if you still see it.

On 08/12/2014 10:41 AM, msacks wrote:

ERROR: API Guard (QP5 version 5.269.14213.34746)

Thread created by msacks
Hi,

Installed the latest Toad Beta this morning and getting a lot of error messages.

The most recent was this (see attached):

API Guard (QP5 version 5.269.14213.34746)

Function 5026 (QP5_CLS_START_CANCELING)

The only thing I was doing was running a Stored Procedure.

Attachments:

2014-08-12_10-36-23.jpg

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.

Will do, thanks!

Hello everyone,

Can any one help me I’m new to Toad i will get error message as “API Guard Issue” what exactly it means? why we will encounter this?

What version of Toad are you on? This is a three year old thread so roughly 5 or 6 releases ago.

I’m having 5.0 version.

On Thu, Jan 12, 2017 at 5:42 PM, Gregory Liss bounce-GTDG@toadworld.com wrote:

RE: ERROR: API Guard (QP5 version 5.269.14213.34746)

Reply by Gregory Liss
What version of Toad are you on? This is a three year old thread so roughly 5 or 6 releases ago.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or Unsubscribe from Toad for Oracle - Beta Forum notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag this post as spam/abuse.

Specifically, what version of Toad for Oracle. This forum is for the beta program and you should be running 12.10 commercial and 12.11 beta.

It is IBM DB2 Version.

On Thu, Jan 12, 2017 at 5:53 PM, Gregory Liss bounce-GTDG@toadworld.com wrote:

RE: ERROR: API Guard (QP5 version 5.269.14213.34746)

Reply by Gregory Liss
Specifically, what version of Toad for Oracle. This forum is for the beta program and you should be running 12.10 commercial and 12.11 beta.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or Unsubscribe from Toad for Oracle - Beta Forum notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag this post as spam/abuse.

This is the wrong forum for your question. You should ask over in the Toad for IBM DB2 forum - www.toadworld.com/…/toad-for-ibm-db2

okay thanks, for the information.

On Thu, Jan 12, 2017 at 6:20 PM, Gregory Liss bounce-GTDG@toadworld.com wrote:

RE: ERROR: API Guard (QP5 version 5.269.14213.34746)

Reply by Gregory Liss
This is the wrong forum for your question. You should ask over in the Toad for IBM DB2 forum - www.toadworld.com/…/toad-for-ibm-db2

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or Unsubscribe from Toad for Oracle - Beta Forum notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag this post as spam/abuse.