Toad World® Forums

Strange error message


#1

http://toadforsqlserver.com/thread.jspa?threadID=36858

It seems to be very similar to the error reported in above link. I had to let it continuw before getting the exact information. Please see above link and if I get this error again, I will be sure to write down the exact information.


#2

I got the error again:

API Guard (QP5 version 5.186.11244.36909)

Function 5117 (QP5_SHL_INIT_CHUNKER): Handle (0xoB621498) Passed to API seems to point to a deleted QP5 object of type SHL.

YES/NO/CANCEL

This is occurring at a very important time/report for me and I really need help with this!


#3

This error is from our parser. Can you isolate what line of code in your script it doesn’t like? When I have seen this error before, clicking on No just ignores the issue and continues. Does the area get executed? Look in the messages tab to see.

Debbie


#4

I am getting this same error, though I am not able to click “no”. I get a window that pops up with the text listed below. With over 500 lines of sql, it would be quite time consuming to try each bit to find the code. perhaps there is some pateren that causes this that I can look for? this is poping up every minute or two and is quite annoying.

Error Text:

System.ApplicationException
QP5 Message => msg 'Function 5117 (QP5_SHL_INIT_CHUNKER): Handle (0x000001ECEA842FA0) passed to API seems to point to a deleted QP5 object.

YES = continue, NO = continue and stop bugging me, CANCEL = abort program’
caption ‘API Guard (QP5 version 5.318.17248.26858)’
type ‘19’


#5

A service request has been created for this customer.