Toad World® Forums

Error configuring 2.7 version


#1

I get the following error when trying to view code snippets in the new version of TDA:

“ActiproSoftware.SyntaxEditor.InvalidLanguageDefinitionException
The highlighting style ‘SyncpointStyle’ was referenced in lexical pattern group ‘SyncpointToken’ however it was not found in the language ‘SQL (DB2)’.
Stack Trace:”

I’m not sure where this SyncpointStyle is being referenced. Can anyone point me to what I need to change?


#2

Try these steps:

  1. Go to About box and click on Application Data Directory. This will open a file browser to config files.
  2. Leave the file browser open from step one and close TDA.
  3. Rename the Application Data Directory. It will be similar to the one below only your name will be the profile name.

C:\Documents and Settings\dpeabody\Application Data\Quest Software\Toad for Data Analysts 2.7

  1. Restart TDA.
  2. This will prompt you to migrate settings. Choose not to migrate any settings.
  3. Go to code snippets and see if you still get the error.
  4. If everything is ok, then go back to dir that you renamed in 3 and copy back your settings.xml and connection.xml.

Note: make sure and follow the sequence above. The application writes the settings when shutting down. So if you do out of sequence you will just get the same settings.

Debbie


#3

Debbie, thanks. That worked!