Error message: Field 'DURATION' not found

I just upgraded to Toad 17.1.717.3711 and each time when I open a new database connection, switch to a different database connection or open a schema browser I get the error message: Field 'DURATION' not found.

Is there any one that knows a solution to get rid of this message?

toad_error

Hi Marc,

Can you turn on Spool SQL so I can see the last few queries executed before the error pops up?

Also, let me know which Oracle version you are connecting to.

Thanks

Edit: I suspect that in a prior version of Toad, you a custom SQL to load tables into the schema browser and that's likely the problem. if so, just add DURATION to the selection list of your query. We added a feature to distinguish between the two types of temporary tables.

Hi John,

Thanks for your fast reply. It's not just when I open the schema browser but the error message also pops up directly after connecting to a database. The Oracle version of the database I am connecting to is Oracle Database 19c Enterprise Edition Release 19.0.0.0.0 - Production.
I turned on Spool SQL and I see that 900+ lines are written. Since I'm not able to add an attachment to my reply (I get the error message: Sorry, new users can not upload attachments.) I uploaded the text to output

Hi Marc,

I have increased your trust level so you can post attachments in the future if needed.

Either of the Schema Browser and Object could be causing this.

I believe that in a prior version of Toad, you set up a custom query in one of these windows, and now it needs to be removed or updated

Uncheck "Custom Filter"

Or, from Schema Browser:

Hi John,

Thank you very much. After unchecking the custom filter I don't get the error anymore.

1 Like

You can add one back in if needed. It should add the DURATION column.