Toad World® Forums

Error Message while opening the Automation Script


#1

Hi - I’ve been using TOAD DATA POINT 3.3 from past one year. Suddenly I started getting following error when I try to open the Automation Script file .TAS

Invalid Element ‘SelectDataActivity.DatasetPublishingOptions’ found while deserializing an object of type ‘Quest.Toad.Workflow.Activities.Database.SelectDataActivity’.

Invalid data found while deserializing an object of type ‘Quest.Toad.Workflow.Activities.Database.SelectDataActivity’.

Please suggest a solution. As I am unable to open it I can’t debug the script itself.

Thanks


#2

Most probably you’ve tried to open your TDP 3.3 script in later version of TDP and then tried to open it in 3.3 again. Is this the case? If yes - you should go the data directory of that later TDP and take unchanged 3.3 script from there. Data directory is here (Windows 7):

C:\Users<your account name>\AppData\Roaming\Quest Software\Toad Data Point

From there go to Automation\bak - here you should find your unchanged 3.3 script.

Igor.


#3

Thank you so much. I had 3.6 installed alongside 3.3 and that was the cause. I was able to recover my script from the path you mentioned. Appreciate your help!