Toad World® Forums

Execute as Script Rounding Problem

Whenever I run a query using F5 (execute as script), any large numbers displayed in the grids are rounded.
If I just do an F9 (Execute Statement), there’s no rounding issue. How do I turn the rounding off for scripts?
There doesn’t seem to be anything obvious in the Toad Options.
For example: 166750890 is rounded to 166,750,889.67

That’s not a Toad issue, that’s just the default behaviour of SQL*Plus.

See: https://forums.oracle.com/forums/thread.jspa?threadID=2156840

Boniest,

If you are running as script then do as below

Column Before format 9999999999.99

Select 166750890.67 Before, ROUND( 166750889.67 ) After from dual ;

Cut and paste above code in Editor and click F5 or Type in front of SQLPlus
prompt will display as below

BEFORE AFTER