Toad World® Forums

Execute Scripts button disabled in the file editor upon creating a new editor

Hello,

I just upgraded to version 7.2.0.233. I noticed that when I created a new sql script editor the Execute Scripts button was disabled by default. I moved back and forth between the tabs and it eventually became enabled.

I also noticed another one. I cancelled a query and the Execute Scripts button didn't revert the icon back to the green triangle, it displayed for a while the red stop sign icon. Eventually, it became green.

Can you guys please fix this, in case you haven't already done it?

Thank you!

Screen Shot 2020-12-07 at 3.14.52 PM

Hi Bogdan,
I'm not sure if that's an issue. It should be disabled when not connected and enable when you write something. Can you give us the exact steps after launching Toad or a short video?

I was using: Microsoft Windows Server 2016 Standard, 10.0.14393 Build 14393 over RDP. I run ToadSS in admin mode.

Today I haven't been able to reproduce it yet after some light use, but yesterday I got to a point where I had a query in the editor and I could not run it because the button was disabled. It happened twice. I don't know exactly what led to that, I went back and forth between connections, running queries, switching connections of scripts.

I never ever had this problem with ToadSS 7.1.0. You must have changed the behaviour of the green button in a subsequent release.

You can choose to believe me, or not. The bottom line is that I do not want to renew the license anymore. I was going to, however, this bug was the cherry on the top. I already spent time writing the original message, and I was disrupted in my work. I cannot debug your product for you. I will try to be aware of my steps in the UI, and if I come across this issue again I will try to figure out the steps and come back to this thread to document them. At this point I am going to leave it at that.

There may be specific steps that trigger this kind of behaviour. We've not come across it yet, but we'll keep it in mind and watch out for it:)
Have you tried doing F5 or even Shift + F5 when that happens? I would also try to Reset all customizations just in case. And the last thing, have you switched from 32 to 64 by any chance?