Toad World® Forums

Execute via F5 works intermittently (TOAD DATAPOINT - Automate)

Hello -
Here is the flow:

  1. Launch my automation script via Windows RUN Window (NOTE: I have a requirement to open the script in this fashion):

  2. The above step will launch TOAD Datapoint (4.3.0718 64bit ver) and will take me to "Automate" screen

  3. Here when I press F5 to execute, the script is not running.

  4. The irony is that if I click my mouse once in the toolbar area (indicated by RED arrow) then if I press F5 then the script will execute (and the script will not execute no matter wherever else I click)

  5. Once it executes in the method as quoted in STEP 4, the script will subsequently execute whenever I press F5 next but if I close and open the script (by following the method as explained in STEP1, then F5 will not work again)

Please let me know what could be the issue. Thanks.

Function keys will respond to the focused subwindow. It appears that when you open in this way the automation window does not have focus. When you click on the tab it gives that window focus.

Hi -Thanks for the update!

I checked that the automation window “does” have focus but still not getting F5 to work.

I suggest you to replicate it once at your end and see.

Yes, I can replicate it now. What is the use case here? Seems like you want to schedule the script to run not edit it. Why not do this with the task scheduler. Then you can have it run unattended when you want it to run.

Hi Debbie -
I have a RPA (Robotic Process Automation) based Use case where in ".tas" script will be "run" by my RPA application as part of a larger execution that contains quite a few other stuff also included.

That is why I am not using the task scheduler.

I see. That makes sense. Does the RPA code offer a way to click the tab to give focus? Or some similar mouse click event? That seems faster than us making a code change.

I tried a way to click the tab to give focus ( by means of mouse click event) but F5 is not getting recognized. Even if I run the script without RPA (double click the script -> wait for TOAD Data point to launch -> click on the TAB to gain focus -> press F5 ) F5 mode of execution is not working.

For now, I am using a click event that will click the "Run button" which in turn will run the script but would love to F5 working.

Very clever. Sounds like a good work around (and I am glad we have more than one way to run scripts:sunglasses:)