Explorer tabs - stop synching?

When using two Explorer tabs (and even the Object Explorer) for the same database, they sync when I change the table filter on any of them. Why is this?
I would like to update/insert data in one Explorer (table) while looking at different data (ie, a foreign key) in another Explorer/table. However, I when I use a filter or just type, the displays are sync'd.
How do I disable this?

Not sure why this might be (what version of Toad for SQL are you using?

Anyway, I'm using v. 8.0 (latest) and the same effect
(e.g. looking at two different tables, etc.)
can be done by ...

  1. Bringing up the Viewer doc tab for your first table from the object Explorer (table rt-click->View Details)
  2. Bringing up one or more other Object Explorers (hit the Explorer ribbon button, or Tools->Explorer) and selecting your second table.

Hope this helps.

Thanks, @Gary.Jerep.

I'm using

So, the non-sync works as long as I don't apply a filter to the tab. As soon as I apply a filter, both explorers sync and the View details tab updates to the top table with the filter applied. We have probably 200+ tables in our databases (don't ask :roll_eyes:). So, to not have a filter is a bit tedious. I have about a dozen filters saved.

Interesting: If one explorer has View tab and the other Table tab, they do NOT keep in sync. But, as soon as I switch one to match the other, the sync'ing immediately occurs.

To me, this is not intuitive behavior for such an interface and I'm puzzled at this "feature".

Is there anyway to disconnect Explorer tabs so that they do not sync?


I don't have access to that old a version, but in the latest 8.0, I can't reproduce this "syncing" effect.
In fact, I can specify different filters (e.g. fact tables listed in one panel, and dimension tables in another panel) and there's no syncing.

When you get the chance, download and upgrade to 8.0, and test again. If you're still getting the same effect, can you let us know how you're bringing up your viewing panels, and provide a screen snap?

Hello Gary,

Thank you for the reply. I was able to finally upgrade to (needed to work through our IT).

Unfortunately, the issue is still happening. I hope there's a setting to turn this sync off. I captured a 32 second video but that MP4 file type isn't permitted to attach. Instead, I have attached a screenshot.
As you can see, all three panels/tabs have the same filter. When I change any one of them, all three change. I hope that helps clarify the issue.


Ah, OK, I see what's happening.

When all your Object Explorers are focused on the same database/object type, then your filter is synced for each OE you have open. I believe this is by design.

We can ask Quest Dev to consider Toad to maintain filter logic by ObjectExplorer/database/ObjectType, not merely by database/ObjectType alone.

A workaround, BTW, might be to spin up another copy of Toad, and have your different object explorers with the different filters. You'll need to turn on the option to allow multiple copies of Toad to run, as per below. Hope this helps for now.

Hello Gary,

Thank you for confirming. Yes, please add this to the enhancement list, perhaps an option under Explorer | General.

Much appreciated,

Notifying the Dev team for their consideration of feasibility and prioritization.

In the meantime, I did verify that the workaround of allowing multiple copies of Toad to run does indeed allow you to have different filters for the same Database and Object Type. Hope that helps you out for now...

1 Like

Hi Gary,

Yes, meant to mention, I have that setting on to allow multiple copies to run at once, which helps with multiple clients. Thank you, again, for confirming that that approach is an option for within the same database.

Kind regards,