Toad World® Forums

Navigation confusion


#1

I am new to Toad for Data Analysts but have used Toad for Oracle.

I’m finding the navigation of the windows very confusing, I think there must be a paradigm shift I haven’t made.

I am trying to browse tables (Oracle tables) using 2 different connections. When I am in one of the connections I have 2 tabs (under Object Details) for 2 different tables. When I switch connections (via the dropdown at the top of the screen), and I double click on a table (in the Object Explorer) it displays the table details in a tab (Viewer Table) next to the Object Details tab. Not under the Object details table where I’d expect it. I can’t seem to get 2 more tables in separate tabs for the other connection.

I’ve looked in the documentation and watched the 5 min videos, but nothing seems to explain this Object Detail tab.

I’m using the Toad for Oracle setup from the Configuration Wizard.

Is there something I should read to get a better understanding of how to navigate objects?

Thanks…


#2

Yes. There are some paradigm shifts.

Let me see if I can answer your question first before I explain the shift.

To view a table there are three different viewers, each with a little different behavior.

Table Viewer

When you double click on a table in the Object Explorer it opens up a table viewer on the right. This is a single table viewer. When you change connections it will not create an additional viewer, but display the currently focused table. This sounds like the behavior that you do not want.

Database Browser

If you go to the Tools Menu and choose Database Browser you will get an window that has an Object Explorer and Viewer together in one window. Every time you click on this menu you will get a new Database Browser and each can be using different connections. Or you can change your connection to that window by using the drop down in the bottom right of the application or connection toolbar. This window is very similar to Toad for Oracle’s Browser.

Object Details

The Object Details window is a dockable window that can be used to browse table data while viewing other windows such as an editor. To have multiple tables to different connections contained in the same Object Details window, use the 'Send To --> Object Details menu, available from the right click menu of the Object Explorer.

Paradigm Shift

When we designed Toad for Data Analysts we tried to create an uncluttered, left to right work flow. To do this we created a set of defaults that do the following:

  • Contain the most commonly used tools in one docked window. Connection manager, object explorer, and project manager. We call this window the navigation manager and set it on the left.

  • The most common work flows are grouped into the following groups: Understand the database, Query the database, Build a report on the data, and the automate the repetitive tasks. By default only one group can have focus at a time. During that time only the windows in the work group are displayed, the others are hidden. This keeps the clutter down but if you are not used to it you might wonder where the windows went. Of course all are available from the window menu.

  • The object explorer drives the single windows on the right. Each of the main windows have a Wizard bar at the bottom to create a left to right workflow. The last action on the wizard bar represents the next step in the work flow. IE: When you are in the Understand group double clicking on a table will bring up a Table Viewer or an ER Diagram, depending on your settings. When in the Query group, double clicking a table will add to a Query Builder, and so on.

New users try the default layout at first. They usually turn off the Quick Guide. Most like the left to right work flow. Many who use multiple connections go through the Custom Configuration Wizard and use a combination of settings. IE: Keep the Wizard bar, but turn off Hide windows per connection or Hide windows per group. I would suggest you give this a try sometime down the road when you are not pressured to get some work done. You may like the conservation of work space. Or find some new combination that works for you.

Debbie


#3

Thank you Debbie. I will explore with the information you’ve kindly provided.

I don’t know why I’m having such a hard time with this tool. I just feel like I’m randomly clicking! But I’ll use your descriptions to try to make sense of it.

Perhaps you can help with another issue: Project Manager. I used this in Toad for Oracle to create an easy way to get to my ‘favorite’ tables. I got some tables listed in the Project manager from one connection, but now every time I R-click on a table object and Send-To Project Manager it just ignores me.

Thanks again…


#4

When you right click and sent to PM it will add to whatever node has focus. Perhaps it is added but not at the root node? But somewhere in the tree? We do not group them under a connection node like Toad for Oracle does. The connection data is contained in the PM node.

Debbie


#5

No, it’s not in the Project Manager anywhere.

However, I did figure out that if I dock the Project Manager I can drag DB tables to the project. But that’s the only way I can get tables in there…

Also, when I tried to add a Query Builder Object (R-Clicking on the tab) I get an error message: Object reference not set to an instance of an object.


#6

What version of TDA are your using? Can you send me a support bundle? Use the Help menu. It should email me a cover letter as well as a zip file. You can send to dpeabody@quest.com.


#7

Just sent to you…

New information - I reconfigured and added the Toolbar Wizard (?) at the bottom of the screen. When I use THAT Add To Project button, adding the Query Builder object to my project works.


#8

Thanks for the files. I can now reproduce the issue. The application wasn’t checking to see if the regular project manager was open before adding the file. This issue was found by our QA and is resolved in the next release (2.6).

I believe there has been a lot more testing done on the TDA layout as opposed to the Toad for Oracle layout you are using. If you find any other issues like this, let me know and I will check to see if they are fixed in the next release.

Sorry for any inconvenience.

I am not able to reproduce the add table to PM issue. If you restart the app, does this issue persist? If so, send me some screen shots and exact steps of how you are adding tables (from what window and what action)

Debbie