Toad World® Forums

Exytract to Excel instance functionality changed with version 12.11.0.61

Good Morning TOAD Team,

  Did a right click Export Data choose Excel Instance; instead of adding a tab to the open spreadsheet (Dry_Run_5_3-31-2017.xlsx) it created a new Excel sheet.  Is this because TOAD does not recognize the newer Excel format (.xlsx vs .xls)?

Larry

703-508-4945

When you write to XLS Instance format, the file is not relevant because Toad communicates with the Excel application itself, it does not touch the file. Maybe it’s due to some setting in that spreadsheet? I’m not sure. I’ve never seen this happen before. Does it do the same with other Excel files? Or maybe you have more than one instance of Excel open and Toad isn’t isn’t picking the one you want it to?

Good Morning John,

    It is very odd; is I export to an instance and save the instance, export to Excel Instance works like in the past; creates a new tab on the open spreadsheet.

    If I create a spreadsheet from Excel, .xls or .xlsx; or if I save, close and reopen the prior export that was working above; TOAD will create a new spreadsheet for the export.

Larry

703-508-4945

Hi Larry.

I tried to reproduce that but it’s working as expected here. I tried both 32 and 64 bit versions. Did you check task manager, in the processes tab, to verify that there is only one copy of Excel running? I have seen multiple copies of excel running in task manager when you can only see one of them on your desktop. That can cause weird behavior. Other than that, I don’t know what could cause this.

If you email me one of your files, I’ll be happy to try it here.

-John

Good Afternoon John and TOAD Team,

    This bug was resolved by ininstalling TOAD beta and reinstalling.

Larry