F2 in Toad for Oracle

Dear Quest

I have the latest version of Toad for Oracle.

In a previous version, if one had a SQL tab open and a package tab open, one could have the SQL tab showing half the screen with the grid at the bottom, and the package tab full screen.

But now, one has to keep pressing F2 every time one switches between the SQL tabsheet and the Package or Stored Procedure tabsheet.

Please can you make it that each tabsheet remembers its own F2 state?


I am unable to reproduce this. You can see my steps in the attached video. Do your steps differ?


Thanks. I see your (or my) problem. Turn off the left hand F8 window.

I don't understand. I do not have the SQL Recall (F8) dock panel open. I closed the Project Manager which I had open and it still works as shown in my video. I tested a second time with the SQL Recall panel open and see the same. Can you expand on what is causing it for you?

How did you open your package? It sounds like your package was opened in a SQL tab. If you have two SQL tabs open then what you describe will occur if the "Auto-save current desktop" option is checked which is the default.

If you load a package from the database it should go to a PL/SQL style tab which allows for an independent desktop from the SQL tab and can be in full screen mode while the SQL remains in the default view.

If you load a package from a file then you can decide which style tab it is loaded in. By default a package with a .pks or .pkb extension will use a PL/SQL tab. If the package is a .sql extension then it will load into a SQL tab. You can force it to use a PL/SQL tab from the file open dialog. Choose "PLSQL" from the "File Format" dropdown.

Thanks for this conversation and for your quick replies.

I'm loading .sql files, .pks and .pkb files, etc, from our GIT Repo on my local machine.

My Toolbar options are the same as yours.

When I have the SQL history tabsheet open, the behaviour is correct. When that tabsheet is closed the behaviour is wrong.

I'm also loading all these tabsheets using a Workspace.

Note the images in your screenshot. Some have "SQL" and some have "PLSQL" on them. Some of your packages are opened in PLSQL style tabs whereas some are in SQL. I have no idea how the SQL Recall panel comes into play as it is completely detached from the Editor. When you observe this issue is it only for tabs that have the "SQL" icon on them? If so, close those tabs, reopen the files, and save your Workspace. If you see any packages loading into SQL tabs then describe the steps you took to open the files in detail, for example, did you open them from Team Coding, the Project Manager, the traditional File Open dialog, or dragging from Explorer into Toad. If you used the File Open dialog did you select one file or multiple to load at once?

The files are all being opened when I open the WorkSpace.

When I watched your first video I saw that the SQL Recall or Project Manager tabsheet was open. If I open it, the behaviour is correct - just saying.

I save my workspace from time to time, depending on what I'm working on. At the moment I have 4 Dev server connections for different schemas that I have rights to, and 3 Production connections depending on rights. Green colour border for Dev; Yellow for Test; Red for Production. A great feature, thank you.

If I close a pkb file and reopen it, it opens as a full window. If I close a .sql file and reopen it (using recent or just open file) then it opens in a full window.

If I press F2, to show the Data Grid, etc, in a SQL file, and then close and reopen the SQL file, it opens with the Data Grid. If I then open the .pkb file, it opens full window. If I then open a .sql file, it opens with the Data Grid.

So it seems to be a problem to do with when I press the F2 and then open the files. ie what was the F2 state when I opened another .sql file or .pkb file.

Now the behaviour is correct so the sequence of F2, and then opening files is significant.

I'll let you know what happens when I reopen the Workspace.

Your desktop is probably set to automatically save which is the default. Close all tabs for PL/SQL code that have the "SQL" icon on the tab. Refer to your screenshot and you'll see some packages are opened in "SQL" tabs. Reopen your packages and ensure they are using the "PLSQL" tab as indicated by the tab's icon. I believe that will sort out everything.

Hi, closing and reopening the tabsheets so that the icons show in the tabheaders has solved the problem. And I hadn't noticed those icons before. Even opening the Workspace works now.

Thanks for your help.

1 Like