F5 not working after multiple F9s across multiple editors


In 17.0.22 (need to update), I have 3 connections -- A, B, C -- and each has their own SB and Editor windows. Each Editor has at least one tab with a script of dozens of DML/DCL/DDL statements. Threaded queries option is enabled. Commit/Rollback all tabs option is disabled. Each statement is executed with F9. While a statement is running in one Editor/tab, I flip to another and F9 the next statement. The single execution is required, as there are pauses for manual validation in between some of the statements.

In Editors for B & C, I eventually need to switch the connection to A, run some statements as above, and at some point, switch the connection back to run more.

All worked super snazzy! I then opened a new tab on connection A and pasted maybe 30 INSERT statements. When I attempted to run them with F5, I got no popup timer/counter, but the execution timer in the lower left hand of the window said "44853 days 13:20:51 hours". Now, Uncle Larry tells us ExaCS/RAC in OCI is fast, so I'm pretty sure the INSERTs didn't take almost 123 years to run. Once I closed all windows and restarted Toad, the script executed with F5 as expected. As the tables have PKs on them, the original execution could not have run. Whew!

Not sure I can recreate this, but thought I'd plop the issue here, just in case it could be helpful...


Hi Rich,

Thanks for the details, and I'm glad it worked after a restart, but the only thing I have to offer is a blank stare.



I figured it was a very obscure scenario, but can't hurt to post it here. :slight_smile:


1 Like