Toad World® Forums

Functionality of the spool subtab


#1

Am I the only one who is annoyed by the functionality of the spool subtab?

It used to work almost fine in 6.1 - since 6.2 it’s almost useless. I hoped it would improve with the new version 6.3. But I am disappointed again .

Things that worked in 6.1 and are now missing:

  1. After switching the tab with Alt-F6, I was able to navigate within the tab using cursor keys, just like within the ‘script’ or ‘editing’ tab. ALL WITHOUT the need of a mouse.

  2. The cursor in the spool tab is missing and the output of the spool tab is not repositioned. When you switch to the spool tab in Version 6.1 a cursor-caret was displayed right at the beginning of the last command you’ve executed. Since 6.2 there is no caret at all and hence the output is not repositioned.

  3. Highlight Text excerpts stream or block wise in the spool windows was possible in 6.1 and now is gone. You can only highlight complete lines - and only using a mouse.

  4. Setting of bookmarks in the spool window was possible in 6.1 and now is gone!

  5. Searching within the spool tab was possible in 6.1 and now is gone!

  6. The output of date values is truncated in spool tabs - this has already been reported at 6.0 I believe and still isn’t fixed.

You may say, that almost all of these features are available, when I copy the entire spool output into a new code editor window. But apparently this not quite the same. For a start: The copied text in the new code editor window is not write protected. I can unintentionally corrupt the spool output. The output in the code editor is not appended, when I run commands in my original script window again. And I can’t jump back and forth using the bookmarks after I re-ran commands.

I am courious what you think about these issues.

  • Markus

#2

Hi Markus Yes there are currently a few with the spool tab, we will try to address some of these in the next release. Thankyou for your feedback.Lidia