Toad World® Forums

GIT bug in Toad 12.8. Toad 12.9 trial key.

Hello. I have a problem in Toad for oracle (12.8.0.49).

In team coding manager VCS directory tree does not display directories with russian names (numbers instead of Russian letters) and their files.

it looks like this: https://yadi.sk/i/MKHdyutjuFTkC

And Log: https://yadi.sk/i/88gBwCrxuFU3t

I tried to change encoding to UTF-8 on toad and git bash, but it didn’t help.

Then a read that in Toad 12.9 new VCS manager and decide to test it, but installing of toad 12.9 trial requires trial License and Site message. And letters with trial key didn’t come to my mail.

trial has been downloaded from https://quest.com/products/toad-for-oracle/software-downloads.aspx

Can you send me trial key for test this problem in 12.9?

Thank you for your help.

Hi beryozavv,

There were some bugs with the Git provider in Toad 12.7 and Toad 12.8. These bugs were addressed with Toad 12.9. If you're current on your maintenance, I would simply recommend downloading the commercial version of Toad for Oracle 12.9 and use that. Your existing license should carry over.

If you're not current on your maintenance, then you can definitely try the trial version. When you install the trial, however, the installer will ask for a license key and site message, as in the following:

If you click on the "License Assistance" link, it will take you to a web page that will help you attain a trial license for Toad 12.9.

-John

Just I checked the new beta version: Toad for Oracle 12.10.0.18.

I found there the same problem:

yadi.sk/…/lqSpu0WruGmTq

Some numbers instead of Russian letters in the names of folders. And folders are empty, although in fact there are files and subdirectories.

What are the options to solve this problem?

Thank you for your help.

Hi Beryozavv,

If you open a command prompt and cd to the root of your Git repository, what are the results of issuing the following command?

git ls-tree --name-only -d HEAD

Also, have you tried turning on "Enable VCS debug logging" in your Team Coding User Settings, seen here:

And if so, can you either post or send me the log file offline? That would help in tracking this issue down.

Thanks!

-John

Hello John.

I have tuned my git using command: $ git config --local core.quotepath false. Then git ls shows the correct result:

vbereza@prog1 MINGW64 /d/vova/GIT/UNA (master)
$ git ls-tree --name-only -d HEAD
1c_export
BOX
Eng test
Russian каталог test
UaMenu
UaMobi2
df
mz
pos
utils
web
Администрирование
Банк Касса Валюта
Бухучет
Зарплата
Кадры
Логистика
Налог
Основные средства
Отрасли
Расчеты
Статистика
Тестовый Russian каталог
Тестовый русский каталог
Торговля
свойства конфигуратора

and screenshot of git bush:

In Toad the result has changed, but it’s still incorrect. Screen:

Encoding option of git bush and toad is UTF-8. Encoding of files is ANSI. (if it has any meaning)

Then i have cleared VCS Log in Toad, logged on to VCS and opened the first five directories.

I’ll send you the log file offline.

Hi Beryozavv,

Thanks for raising this issue. I was able to reproduce it using the examples you provided. The problem was being caused by a difference in how command-line tasks handled filenames between older versions of Windows (like Windows XP) and newer ones (Windows 7+). In older versions of Windows, file names were reported using OEM character sets. As a result, we included some code to convert those OEM characters whenever necessary. Newer versions of Windows don’t require this since they store and report file names using Unicode character sets.

I’ve fixed the problem for Monday’s beta. If you get the chance, feel free to give it a shot then and let me know if this corrects the issue on your machine.

Lemme know if you have any questions!

-John

Hello, John. I have just checked the new beta version of Toad for Oracle 12.10.0.20.

The problem is solved. Displaying and opening Russian folders works fine!

Our team is very grateful to you for the excellent work!

The final screenshot of the correct display: